[Résolu] Export d'exercices Moodle pour Opale 3.8 et 3.9

Bonjour @stephanep ,
est-ce qu’une version de l’extension « export exercices Moodle » pour Opale 3.8 est sur les fourneaux ?
On vient de passer notre académie entière sous Moodle comme LMS (académie de Normandie passe sous l’ENT libre NEO qui comprend Moodle).
bonnes vacances,
Patrice

Salut @patrice
Tu peux trouver une version « non officielle » ici : Export moodle pour opale 3.8
@sam on peut peut-être la mettre dans download non ?

Bonjour,
pour info : cette version de l’export d’exercices Moodle fonctionne bien dans le scenarichain classique mais pas dans le NG avec Opale 3.9
cordialement,

Hello, peux-tu détaller ? Il se passe quoi quand ça ne fonctionne pas ?

Il n’apparaît pas dans la liste des extensions dans Opale 3.9. En bref il ne s’intègre pas à Opale 3.9 Alors, forcément, les items export Moodle existant apparaissent comme des items non reconnus par Scenari.

Dans le scChain classique où ça marche, c’est quelle version d’Opale ?

C’est avec Opale 3.8 que ça fonctionne. Quand on passe en Opale 3.9 sur le ScenariChain classique ça ne fonctionne pas (pas présent dans les extensions à cocher dans l’édition des propriétés du modèle Opale.

ok, dès que je remets la main sur les sources, je compile l’extension pour Opale 3.9.

Teste ça. Ça semble marcher correctement chez moi. Si c’est bon de ton côté, dis-moi et je le mets sur la plateforme des contributions.
MoodleExport_18.2.1_202108171307_sc50.wsppack (407,9 Ko)

Bonjour,
quelle réactivité dis-moi :slight_smile:
je viens de tester sur un de mes modules et il a correctement généré un fichier d’export fonctionnel.
Je testerai davantage dès la rentrée car il me faudra remettre en place tous mes modules de formation sur Moodle :hot_face:
merci beaucoup et à bientôt,
Patrice

Okay nickel. Pense à me donner une OK définitif quand tu pourras pour que je le mette sur la plateforme des contributions dès que possible.