Mise à jour de MyScenari

Bonjour,

Les serveurs myScenari ont été mis à jour aujourd’hui.

L’interruption de service sur les dépôts à duré 30 minutes en début d’après-midi. Les entrepôts ont eux été inaccessibles pendant l’après-midi. L’accès est rétabli. Attention, on a un contre-temps sur les extensions (extensions contenant le skin myScenari, les générateurs dédiés aux dépots et le bouton “diffuser”). Elles seront mises à disposition dans les prochains jours.
Il est à nouveau possible de créer des nouvelles instances.

Côté nouveautés :

  • Les serveurs Scenari ont été mis à jour (serveur saas et instances chain/depot)
  • Les modèles ont été mis à jour vers les versions bêta récemment publiées.
  • Le client inclut maintenant un entrepôt local (équivalent SCENARIchain) avec les trois modèles libres (opale, dokiel, optim) dans leurs dernières versions bêta.
  • Les extensions arriveront bientôt avec un item dédié aux accueils de depot dans Optim et un processus de génération et diffusion simplifié pour les trois modèles.

N’hésitez pas à faire parvenir des retours, bugs, souhaits pour une prochaine version… en réponse à ce message.

Thibaut

bonjour,
Depuis la mise à jour, alors que mon client est à jour en version 4.2.115, quand je clique sur “rechercher des mises à jour”, il m’est proposé de mettre à jour… vers la version 4.2.115.
Cordialement,
Emmanuel Farcy

Bonjour,

si j’ai bien compris il faut attendre l’extension myDepot pour pouvoir mettre à jour son dépôt ?

sinon, RAS, pas de bogue détecté pour le moment.

Merci pour cette mise à jour

Et voilà, de notre côté tout est bon.

Les extensions sont installées et vous pouvez mettre à jour vos dépôts directement depuis myScenari (ce qui n’était en effet plus le cas avant).

Merci pour l’extension myDepot, ça fonctionne.

Pour le fil d’ariane c’est à nous de le remettre à la main en éditant le style avec ScenariStyler ? Il suffit de suivre la doc pour ce faire ? Car en fait il est présent mais il ne reprend pas le titre qu’on a saisis mais le nom du paquet de génération (qui est parfois peu clair).

à bientôt

Bizarre la génération de la page d’accueil : voir https://bionet.scenari-community.org/co/siteWeb.html#rqFWXE5QftiyfNtOELRu0
En fait la régénération de la page d’accueil m’a supprimé tous les autres apports à myDépôt.
De plus, l’extension pour Opale ne semble pas être fonctionnelle : elle refuse de s’activer lorsque je la sélectionne.

Bonjour,

En effet, il y a un soucis sur votre page d’accueil. Il s’agit d’une ressource de type “archive” au lieu d’une ressource de type “accueil de dossier”.
Lorsque vous manipulez les options de génération (checkbox fil d’Ariane et accueil de dossier), faites attention à bien regénérer votre document avant de l’envoyer.
Pouvez vous mettre à jour votre accueil ? En cas de soucis, on pourra remettre votre depot dans l’état où il étant avant migration (si besoin).

Les autres points que vous avez soulevé (Opale, fil d’Ariane) ont été corrigés.

Bonjour,

merci pour ces mises à jour.
J’ai un soucis : refus de publier sur mydepot pour ma page optim (aucune réaction au clic sur l’icone) ;
Concernant la précédente génération et export vers mydepot de la page d’acceuil : je n’ai pas de trace du répertoire contenant l’archive ; j’avais bien généré une archive que j’ai dû importer dans myDepot en cliquant sur l’onglet «Import» car je n’ai plus le bouton en bas comme avant pour mettre à jour la page d’accueil.

De plus, lorsque j’ai déjà publié une archive (en saisissant nom et titre alors qu’auparavant seul le titre était demandé puisque le nom était le nom généré pour l’archive) je ne peux plus en publier d’autre, je n’arrive qu’à écraser l’autre archive.

Bilan je ne peux plus placer qu’une seule archive sur myscenari et plus mettre à jour la page d’accueil.

On a désactivé la rediffusion automatique dans l’extension Optim pour éviter que d’autres personnes n’effacent un dossier par erreur (probablement à l’origine de l’écrasement de votre accueil). Vous pouvez à nouveau déployer depuis Optim mais il faudra sélectionner le dossier cible systématiquement en attendant qu’on ait une meilleure façon d’éviter ces écrasements.

Pour votre dépôt, on peut le faire revenir à son état avant migration (mardi dernier) si vous voulez.

bonjour,
Et pour la demande de mise à jour qui boucle, suis-je le seul ?
Cordialement,
Emmanuel Farcy

Bonjour,

En effet, on a bien constaté l’erreur. Ce sera corrigé ultérieurement.

Bien à vous,

Je n’ai pas besoin de revenir à l’état avant migration. L’essentiel c’est que je puisse replacer mes 5 générations et les référencer sur ma page d’accueil.

merci pour ces correctifs

NB : mais cela serait peut-être plus pratique de carrément remettre à zéro mon myDepôt au niveau du serveur pour repartir sur des bases saines

C’est bon pour Optim et la page d’accueil.
J’ai toujours le problème de mes autres paquets d’archive : myDepôt veut bien me les prendre en écrasant une autre archive déjà présente (ce qui explique que je ne puisse pas en avoir plus d’une sur mon espace public). C’est peut-être que les anciennes archives sont encore répertoriée dans myDepôt sans être là physiquement.

Mais bon, même en changeant le nom de l’item de génération web je n’arrive pas à diffuser mon archive sur mydepot.

Le fonctionnement par défaut du bouton “diffuser” a changé.
Avant, il vous était systématiquement possible de choisir la cible de diffusion et en cliquant sur le menu deroulant, vous pouviez “rediffuser” automatiquement au même endroit.
Maintenant, c’est l’inverse. Par défaut la ressource est rediffusée au même endroit et en cliquant sur le menu déroulant à côté du bouton, vous pouvez déployer vers une nouvelle cible.

On a inversé ce fonctionnement car dans la grande majorité des cas, les usagers veulent juste mettre à jour une ressource.

Je n’ai pas de menu déroulant à coté du bouton «diffuser».

Je vous propose de poursuivre la discussion en messages privés pour bien comprendre votre problème.

Tout marche nickel (à part une alerte de nouvelle version qui apparaît régulièrement et qui lance le téléchargement de la même version… enfin pas exactement : la version réellement installée n’est pas celle qui est citée dans le à propos, voir les messages à ce sujet d’ emmanuel_farcy ).

Pour résoudre tous mes problèmes de configurations farfelues il m’a suffit de supprimer le répertoire perso .scenari/myscenari4.2 .

J’avais quelques appréhension avec l’habillage myScenari qui ne convenait pas pour les questions sous Opale mais il y a eu un très gros travail sur ce skin qui a un rendu nickel. C’est dommage qu’on n’ai pas de version de ce skin pour Webmédia car cela me permettrai d’importer des archives adaptées à mon mydépot.

En bref : félicitations à toute l’équipe car ce myscenari est sublime : https://bionet.scenari-community.org

Quand une archive est supprimée mais qu’elle est encore dans la corbeille elle est listée par le script qui est dans la doc.

Bonjour,
Il me semble qu’avant la migration récente, il était possible de faire un export pdf dans “publication papier” dans un item “Support papier”.
Maintenant, on n’a plus cet possibilité : juste l’export en opendocument.
Commetn récupérer cette possibilité ?
Cordialement,
Emmanuel Farcy

Bonjour à tous,

myScenari a été mis à jour en version 4.2.17.

La mise à jour contient quelques corrections de bugs suite à des messages postés sur les forums :

Cette version de myScenari n’inclut pas le genPdf d’Opale qui n’est pas encore prêt.
myScenari en version desktop inclut désormais SCENARIstyler.

Thibaut