Problème avec les ressources images dans Opale 3.6 [RÉSOLU]

Bonjour à toutes et tous,

Je rencontre le problème suivant avec Opale 3.6 à la fois sous Ubuntu 14.04 et 16.04 :

Lors de la création d’une ressource «image» (jpg, png, etc.) tout se passe correctement. Je peux voir l’image, modifier sa dimension, etc.
Mais lorsque je l’intègre comme ressource dans un « grain » par exemple, j’obtiens un grand carré gris avec un croix au centre.
Le même carré gris apparaît en vignette si je passe la souris sur le nom de la ressource dans la zone de gauche.
Or l’image est bien présente dans le dossier «sources» d’Opale 3.6.

Le problème est aussi visible avec mon atelier créé avec Opale 3.5 sous Ubuntu 14.04 et importé dans Opale 3.6 (par la technique de migration officielle).

Pensez-vous qu’il s’agisse d’un bug de cette nouvelle version ou d’un problème lors de l’installation d’Opale 3.6 ?

Je vous remercie par avance pour vos réponses.

Mickey2l

Bonjour
Sous Windows, tout fonctionne correctement pour les images. Le test est positif pour les deux versions (Starter et Advanced) d’opale 3.6.
J’ai renommé mon image en caractères non latins, j’ai abouti au problème que vous avez évoqué. J’espère que cette piste serait utile.
Cordialement

Merci Mohammadine Chakht pour votre réponse.

Malheureusement sur mon OS, le problème semble ne pas venir de là.
En effet le problème persiste avec des noms simples comme : 123.jpg ou image.jpg ou encore toto.png
Et cela même si je renomme directement les images dans Opale.

Résultat identique dans les deux versions (Starter et Advanced).

Cordialement

Bonjour,
je suis sous Ubuntu 16.04 x64 et je n’ai pas ce problème, je ne l’avais pas non plus sous 14.04.
J’avais déjà eu quelque chose de ce type il y a quelques années et ça provenait d’un résidu de config d’une install précédente (lié à une mise à jour d’Ubuntu). La réinstallation out of the box d’Ubuntu avait permis de remettre à zéro certaines config (je ne me souviens plus lesquelles) et repartir sur des bases saines et fonctionnelles.

cordialement,

Bonjour, Patrice,

Merci pour votre aide.

J’ai installé directement Opale 3.6 sur Ubuntu 16.04 x64. Sans ancienne version

J’ai un doute avec « La réinstallation out of the box d’Ubuntu » ?
Réinstaller Ubuntu à partir du CD d’Ubuntu sur la version existante (une réparation) ;
ou
Refaire une installation d’Ubutnu à partir du CD en effaçant l’ancienne version, puis en réinstallant Opale 3.6 ?

Je penche pour la première sachant que «out of the box» se traduit par « faire de façon non conventionnelle ».

Cordialement

Avant de toucher à votre installation, on va regarder certaines choses !
Vous avez installé Opale comment ?

  1. en deb depuis le dépôt scenari.org
  2. en tgz
  3. en wsppack dans SCENARIchain installé en deb
  4. en wsppack dans SCENARIchain installé en tgz

Vous utiliez quel architechture de Ubuntu ?

  1. 32 bit
  2. 64 bit

Bonjour, Sam,

Je travaille sur Ubuntu 16.04 x64 , bureau Gnome.

Après importation de la clef PGP, j’ai suivi la procédure donnée à cette page :
http://scenari-platform.org/trac/scenari/wiki/InstallLinux#InstallerlesprogrammesSCENARIsurUbuntuetDebianpourlesnondébutants

Soit :
sudo -s
echo “deb https://download.scenari.org/deb lucid main” >> /etc/apt/sources.list
apt-get update
apt-get install <nom_de_la_scenariapp>

Le tout contextualisé pour Ubuntu 16.04

Merci.

Bonjour,

Lorsque tu dis que tu as contextualisé pour Ubuntu 16.04, cela signifie-t-il que tu as corrigé le «lucid»en «xenial» dans le fichier /etc/apt/sources.list ?

cordialement

NB : out of the box signifie également «sans manipulation, directement sorti de l’emballage». Je parlait ici d’une installation en formatant le disque, soit une installation d’Ubuntu à partir de zéro.

Bonjour Patrice,

Exact : j’ai remplacé «Lucid» par «Xenial».

Donc, tu me suggères de formater, puis de réinstaller Ubuntu puis Opale, etc.

D’accord, mais la question que je me pose est alors la suivante : pourquoi sous Ubuntu 14.04 (une autre machine) j’ai les mêmes symptômes après l’installation d’Opale 3.6 ? Alors qu’Opale 3.5 fonctionne correctement sur la même machine.

La nuit porte conseil !

Merci, bien à tous de prendre un peu de votre temps pour m’apporter de l’aide !

Cordialement

Bonjour Mickey2l

je ne suggère rien du tout au niveau de tes installations d’Ubuntu :grin: Je me borne a dire que, dans mon cas, j’avais résolu le problème par une installation propre. À noter que ce problème je l’avais rencontré il y a longtemps, certainement avec une version bien antérieure à la 3.5 alors je ne pense pas que cela soit dépendant de la version.

Avant de tout reformater il y a certainement des choses à tester pour trouver d’où vient vraiment ce problème. Samuel serait certainement d’une grande aide à ce niveau. Et cela permettrait de pallier à ce soucis pour d’autres utilisateurs à l’avenir.
Peut-être qu’un simple effacement du répertoire des paramétrages perso de scenari (/home/user/.scenari) corrigerait le problème mais rien n’est moins sûr puisque les paramètres perso sont séparés par version de scenari dans des sous-répertoires distincts. En général les paramétrages perso se résument aux modèles documentaires installés dans scenarichain, il suffirait alors de réinstaller ces modèles puis de recréer les ateliers en cliquant sur «reprendre cette définition de l’atelier» puisque ces ateliers seraient toujours présents dans le répertoire SCchain4.2 (si tant est que tu utilises SCchain, sinon remplacer par l’application autonome correspondante).

Maintenant je puis t’affirmer que j’ai 2 systèmes Ubuntu 16.04 x64 installés sur un Desktop et un laptop et que je n’ai pas cette erreur. J’ai également installé par dépôt. Seule différence, mais je ne pense pas que cela joue, c’est que ma liste de dépôt n’est pas dans sources.list mais dans sources.list.d/scenari.list puisque j’ai suivi l’installation de la page de la doc ubuntu qui ne diffère que sur ce point.

Concernant ton autre machine, si à l’avenir tu la passes sous 16.04 alors essaie d’installer tout de suite Scenari pour voir si le problème se reproduit sur une installation propre et tu pourra ainsi peut-être trouver quelle manipulation ou installation de logiciel provoque une incohérence au niveau de Scenari (mais certainement aussi au niveau d’autres logiciels ; je me souviens maintenant qu’en même temps j’avais d’autres trucs qui ne voulaient pas fonctionner comme SweetHome3D écrit en java si cela peut aider Samuel ).

cordialement

Bonjour Patrice,

Lors de mon inscription à ce forum, l’idée était de pouvoir discuter avec des personnes bien plus qualifiées que moi, mais aussi, ma pleine et entière responsabilité si je prenais la décision de suivre une information, une piste, une suggestion ou une description d’une situation personnelle.

Les différents échanges rencontrés dans ce sujet répondent exactement à mon attente et je vous en remercie.

L’idée d’une installation «out of the box» faisait déjà partie de mes solutions avant même de venir ici, avec l’idée d’installer Opale en premier et de voir à quel moment le problème survenait. Le même problème sous 14.04 me faisant pencher pour un conflit entre applications (les deux machines ont le même lot de logiciels).

Je suis tout à fait d’accord avec toi qu’une solution en l’état serai bien plus agréable (pour moi) et surtout comme tu l’as écrit : «Et cela permettrait de pallier à ce soucis pour d’autres utilisateurs à l’avenir.».

Mon intention était de basculer ma deuxième machine sur 16.04 dans un ou deux mois. Je vais peut être avancer cette échéance et en profiter pour faire le test.

Je te souhaite une agréable journée.

Cordialement

Bonjour,

La solution était au final très simple !

Après une réinstallation complète d’Ubuntu 16.04, le problème était toujours le même. Comme il touchait le traitement des images, je me suis penché sur la manière dont Opale gérait ce type de ressources.

Et j’ai découverts qu’Opale utilise ImageMagick comme éditeur externe. Et dans une ancienne discussion de ce forum, j’ai pu lire que quelqu’un avait rencontré une erreur du pointeur d’ImageMagick.

Dans les préférences de l’atelier, on peut pour ImageMagick soit utiliser « la version par défaut du système » soit définir un emplacement personnalisé.

J’ai donc opté pour un chemin personnalisé en indiquant : /usr/bin

Résultat, Opale peut correctement manipuler les images et les intégrer dans un grain par exemple.

Il semble donc que dans certaines installations (peut être lié à la nature du bureau utilisé) l’emplacement de « convert » ne soit pas celui attendu par Opale.

Merci à tous de votre aide.

Problème résolu

Bonjour,
je suis bien content que tu ai trouvé la solution. Je venais rédiger une note additive quand j’ai vu ton message : je venais de reproduire ton erreur sur une XUbuntu 14.04 32bits sur le petit ordi de ma fille.

Pour info : tu as noté cette différence de pointage vers ImageMagick sur quel bureau ? Personnellement, sous Unity il n’y a pas de soucis. par contre le problème est effectivement réglé avec le chemin personnalisé sur Xfce.

Merci pour ta réinstall formatrice :slight_smile:

Bonjour Patrice,

Merci et je constate que nous avons eu la même idée. :slight_smile:

Je suis sous la variante officielle Ubuntu Gnome (Environnement Gnome Shell par conséquent) x64 sur un Desktop.

Avec plaisir, si ma toute petite « pierre » apportée au forum pourra aider les utilisateurs d’Opale (Superbe application au passage !)

Bonne journée à tous.

Bonjour,

Ce problème n’a rien a avoir avec la version de Ubuntu mais est uniquement dû à un bug dans le packaging DEB des scApp (Opale, Optim, Dokiel). Ce bug n’est pas présent dans le packaging DEB de SCENARIchain.

Correction en cours.

Bonjour,

Merci pour cette info Sam.
Courage aux concepteurs pour les correctifs, et merci pour leur travail.

Bonjour Opale 3.6.015-s2 disponible dans le dépôt ce matin corrige ce problème. Merci de l’avoir remonté.

A Mickey21

Je viens tout juste d’installer Opale et j’ai ce problème de “carré gris avec une croix au centre” au lieu d’avoir l’image que j’ai téléchargé. Je regarde les réponses qui ont été données et je ne trouve pas la solution. Est-ce qu’il y en a une facile: faut-il retélécharger OPALE; est-ce une question du format de l’image?..bref, qu’est-ce qu’il faut faire?

Merci !

SLM

Bonjour,
Quel Version d’Opale sous quel OS ?

Bonjour! Pardon d’avoir tardé à répondre, mais je ne pensais qu’on lirait mon message si vite!

Voilà: j’ai la version d’OPALE 3.6 et je suis sous “OS EL Capitan”.

Merci ! Là je guette la réponse (sourire)

Sylvaine