Problème lancement Opale3.7 sous Ubuntu 16.04

Bonsoir,

J’ai voulu installer Opale3.7 sur mon PC Ubuntu 16.04 mais au lancement j’ai un message d’erreur : «Your opale3.7 profile cannot be loaded. It may be missing or inaccessible» Je précise que j’avais Opale3.5 qui marchait bien au début puis qui m’indiquait, depuis plusieurs mois la même erreur. J’ai tenté de chercher sur le forum mais je n’ai rien trouvé.
Quelqu’un pourrait-il m’aider ou m’indiquer où chercher ? J’ai désintallé proprement Oaple 3.5 (sudo apt remove). Pour installer Opale3.7 j’ai suivi la procédure du site (apt install etc. après avoir installé le dépôt comme indiqué, aucun pb jusque-là c’est au lancement que cela ne fonctionne plus). Une idée ?

Merci d’avance,

Cordialement,

        Richard

Très longtemps, j’avais eu ce genre d’échec d’installation. Si vous pouvez désactiver votre Antivirus pour réussir correctement le téléchargement et l’installation de votre opale. Après , Réactiver votre Antivirus

@Mohammadine_Chakht : sous Linux il y a peu de chance que ce soit un problème d’antivirus :slight_smile:

@Richard63 : pourriez vous éventuellement tester l’installation de SCENARIchain desktop + le wsppack opale ?

Cela vous ramènera vers le mode d’installation le plus courant et le plus souple. Si cela fonctionne mais que vous avez besoin d’aide pour charger vos contenus dans ce nouveau déploiement, laissez un message de plus dans ce fil de discussion.

1 J'aime

Je n’ai pas d’antivirus pour l’instant, c’est une de raisons pour lesquelles j’ai choisi Linux.
Merci pour la piste mais ce n’est pas cela.

Bonjour,
OK, merci pour l’info. Je vais faire cela aujourd’hui et je vous tiens au courant pour la suite. Merci beaucoup pour vos disponibilités à tous.

Pouvez-vous lancer Opale en ligne de commande et nous transmettre les logs ainsi générés ?

Bonjour,

Je n’arrive pas en fait à repérer le dossier Opale sur mon PC. Quand je le lance à partir de Nautilus il me met ce message d’erreur mais quand j’essaie avec la console je ne trouve pas le dossier avec le lanceur.

@stephanep

J’ai fait ce que vous avez préconisé. J’ai installé scenarichain desktop avec le lien que vous m’avez fourni et en suivant l’installation avec apt. j’ai installé ensuite Opale 3.7 mais comme il est déjà intallé le système m’a simplement répondu que j’avais la version al plus à jour…
Ensuite j’ai lancé le logiciel avec nautilus mais j’ai toujours le même problème.

[EDIT] : je viens de me rendre compte que je me suis trompé, je n’ai pas installé le wsppack opale.Je l’ai fait et j’ai le même résultat (voir mon post plus bas).
Merci pour la piste mais ce n’est pas la bonne.

Dans le dossier caché .scenari qui est dans mon dossier utilisateur, il y a un autre sous-dossier Opale3.7 mais celui-ci est entièrement vide. J’imagine que c’est là qu’il devrait y avoir mon fichier profil, non ?

je viens de trouver le dossier opale3.7 dans /usr/share je devais avoir la berlue, désolé. À toutes fins utiles voici le contenu du fichier <launcher.conf> :

app

xulrunner=xulrunner/scenari
inifile=scApp/application.ini
localization=fr-FR
chrome=scApp/chrome

resources

name=Opale

Je ne sais pas si cela peut aider. En revanche j’ai essayé (sans grand espoir) de lancer Opale avec «sh launcher.conf» ce qui a donné le résultat escompté c’est-à-dire à peu près rien. Voici les commentaires de la ligne de commande :

/usr/share/opale3.7$ sh launcher.conf
/usr/share/opale3.7$ # app
/usr/share/opale3.7$ xulrunner=xulrunner/scenari
/usr/share/opale3.7$ inifile=scApp/application.ini
/usr/share/opale3.7$ localization=fr-FR
/usr/share/opale3.7$ chrome=scApp/chrome
/usr/share/opale3.7$
/usr/share/opale3.7$ # resources
/usr/share/opale3.7$ name=Opale

Voici la liste des fichiers que j’ai dans mon dossier Opale3.7 :
launcher.conf restart-required.update-notifier scApp scServer

Que puis-je essayer d’autre ? Comment lancer Opale à partir de la console (quel dossier autre que celui-ci ? Quel fichier ?) ?
Merci beaucoup.

Les messages de la console sont non reproductibles : quand je tape «sh launcher.com» il se passe plus rien. Le prompt clignote puis devient fixe.

@stephanep

J’ai fait tout cela. Quand je lance le wsppack d’opale, il me dit que je n’ai aucun logiciel qui permette de lancer ce type de fichier. Or j’ai bien installé Scenari. Quand je lance Scenari dans Nautilus, j’ai la même erreur qu’avec Opale : profile missing.

Bonjour Richard,

Le problème de SCENARIchain qui ne se lance pas est le plus important ici.
(si une solution est trouvée, vous pourrez installer le pack de cette manière : https://doc.scenari.software/SCENARIchain-desktop@4.2/reference/fr/#installModDocLocal )

Vous devriez avoir le répertoire : ~/.scenari/ch.4.2

Vérifiez que ~/.scenari et ~/.scenari/ch.4.2 sont bien possédés par votre user et non par root, qu’il y a au moins les droits drwx------

Bonsoir,

Merci de vous occuper de mon problème. Pour l’instant j’ai tout désinstallé et essayé de nettoyer les fichiers pour pouvoir refaire une installation propre. Ce qui n’est pas une mince affaire, même avec apt purge, il en reste. Je vais réinstaller scenarichain ensuite. Je ne sais pas si d’autres que moi ont eu le même problème…

Est-ce que quelqu’un pourrait me dire ce qu’il devrait y avoir dans le dossier /.scenari/opale3.7 puisque le mien est vide ?

Merci.

Bonjour,

Désolé de vous ennuyer avec mon pb. Opale rencontre toujours le même pb sur mon PC sous Linux Ubuntu 16.04. Cette nuit j’ai nettoyé mon système, retiré manuellement des fichiers d’install qui traînaient encore, etc. puis réinstallé Opale3.7 et pour voir Opale3.6. Toujours rien ne marche, toujours le même message : «Your opale3.7 profile cannot be loaded. It may be missing or inaccessible»

Est-ce que quelqu’un pourrait m’expliquer la signification de cette erreur du point de vue du fonctionnement du logiciel. D’après ce que j’ai cru comprendre le logiciel est développé en Java et en XUL. Ce fameux fichier de profil est-il créé par le logiciel à l’installation ou lors du premier lancement ? Puis-je faire un texte avec un fichier de profil que quelqu’un pourrait me mettre à disposition, voir si cela résout mon pb ?
Merci d’avance.

Bonjour,

Un peu de patience, je suis en train de regarder votre problème, je reviens vers vous quand j’ai un env de test réel.

Bonjour,

Je viens de tester Opale 3.7 et SCENARIchain 4.2 sur une installation neuve de Ubuntu 16.04 sans aucun problème :

Ceci en suivant très exactement les directives sur https://download.scenari.software soit :

echo "deb https://download.scenari.org/deb lsb_release -sc main" | sudo tee -a /etc/apt/sources.list.d/scenari.list
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com C1B92A9981DBBE62
sudo apt update
sudo apt install opale3.7.fr-fr
sudo apt install scenarichain4.2.fr-fr

J’en déduit que vous avez donc un problème qui est spécifique à votre machine.

Que voulez-vous dire exactement par :

Lancez les applications simplement à partir du HUD non ? Comme ceci :

Mais pour quoi faire ? L’application Opale est sur votre path :

Avez-vous assez de place sur la partition ou se trouve votre /home ?

Bonsoir,

merci pour vos conseils. J’ai réinstallé en suivante scrupuleusement les directives d’installation mais toujours le même problème. Ce doit être spécifique à mon ordinateur j’imagine.

  1. Oui je voulais dire le HUD :

  2. Rien ne marche quand je lance à partir de Home.

  3. Je vais vérifier ce pb de place. C’est possible en effet. J’ai un autre disque dur : est-il possible de forcer l’installation de tout cela sur ce 2nd disque dur ?

Merci pour tout.

Pouvez-vous tapper les deux commandes suivantes dans un terminal :
ll ~/.scenari

et :
df -h

Exemple :

Voici le résultat. Je n’ai manifestement pas la commande ll
Fait-elle partie d’un paquet particulier et optionnel ?

[EDIT] désolé j’ai de la choucroute dans le cerveau aujourd’hui…