Installation Scenarichain-server 5 Debian

Bonjour,

cela fait plusieurs fois que je tente l’install en suivant la documentation (la jessie).
J’ai bien /var/lib/jetty9/webbapps/scenarichain-server5.0.war
Tout s’est installé dans /usr/share/scenarichain-server5.0/
Jetty et Nginx semble ok (dans nginx j’ai ajouté le reverse proxy suivant la doc).

Mais quand je lance :
http monsite:8080/scenarichain-server5.0/&
J’ai un « chargement » qui apparait et ça s’arrête là :confused:
ou
https monsite:8080/scenarichain-server5.0/&
Là j’ai Page impossible à ouvrir.

Avez-vous déjà eu ce cas de figure. Parce que je ne comprends pas ce qui bloque…

Lilian.

C’est sur un site distant, ou sur un réseau local (pour pouvoir éliminer tout souci causé par un élément réseau intermédiaire, genre filtrage d’un port dans un parefeu…) ?

ou https
ce n’est pas du tout la même chose.

Peut-être que cette discussion suivante peut aider à trouver le bon certificat si le serveur est sécurisé en https :

Bonjour,

c’est en dmz mais et le pare-feu et l’iptables laissent passer http/https/et les deux sur le 8080.
J’ai également ouvert tout ip entre mon poste et le serveur.

Lilian.

Par contre quand je retire la redirection en :8080 pour passer en 443 standard, je retombe sur la même page qu’en http : « Chargement » affiché et rien de plus. Le certificat est bien reconnu et valide.
C’est comme si Scenari ne parvenait pas à lancer quelque chose pour que j’arrive sur la page d’authentification.

Grâce à un test avec Firefox j’ai effectivement une erreur en :8080. Je traiterai cela dans un second temps si c’est possible.

Dans les logs d’accès j’ai bien des codes http 200 :
[04/Dec/2020:17:52:11 +0100] « GET /scenarichain-server5.0/& HTTP/1.1 » 200 747 « - » « Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0 »
[04/Dec/2020:17:52:11 +0100] « GET /scenarichain-server5.0/~~static/fr-FR/home.xhtml HTTP/1.1 » 200 4205 « https://scs5.cnam.fr/scenarichain-server5.0/& » « Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0 »
[04/Dec/2020:17:52:11 +0100] « GET /favicon.ico HTTP/1.1 » 404 143 « - » « Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0 »
[04/Dec/2020:17:52:11 +0100] « GET /scenarichain-server5.0/~~static/fr-FR/home.js?1595245523172 HTTP/1.1 » 200 6850 « https://scs5.cnam.fr/scenarichain-server5.0/~~static/fr-FR/home.xhtml » « Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0 »
[04/Dec/2020:17:52:11 +0100] « GET /scenarichain-server5.0/~~static/fr-FR/res/logo.png HTTP/1.1 » 200 9800 « - » « Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0 »

J’ai un petit warning de jetty :
14:11:18.337:INFO:oeja.AnnotationConfiguration:main: Scanning elapsed time=0ms
14:11:18.392:INFO:oejshC.scenarichain_server5_0:main: Warning: No org.apache.tomcat.JarScanner set in ServletContext. Falling back to default JarScanner implementation.
14:11:18.507:INFO:oajs.TldScanner:main: At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.

Je ne sais pas trop ce qui ne lui plait.

Merci de m’avoir répondu. Je continue de creuser :confused:

Lilian.

Ceci veux dire que vous vous connectez directement à Jetty, pas à Nginx, mais peut importe.

  • Vous avez bien installé par apt ?
  • Vous ouvrez bien monsite:8080/scenarichain-server5.0/& avec un navigateur basé sur Chrome ?
  • Vous avez quoi dans les logs ? (un fichier /var/log/scenarichain-server5.0/xxxx.log par jour)

Bonjour,

oui je suis bien passé par l’apt :
dpkg -l scenarichain-server5.0-jetty9
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
++±=============================-===================-============-==============================================
ii scenarichain-server5.0-jetty9 5.0.7-x202007201345 all SCENARIchain-server 5.0 - Jetty 9 integration.

dpkg -l | grep jetty
ii jetty9 9.4.15-1 all Java servlet engine and webserver
ii libjetty9-extra-java 9.4.15-1 all Java servlet engine and webserver – extra libraries
ii libjetty9-java 9.4.15-1 all Java servlet engine and webserver – core libraries
ii scenarichain-server5.0-jetty9 5.0.7-x202007201345 all SCENARIchain-server 5.0 - Jetty 9 integration.

Lorsque je rentre l’url j’ai une page blanche avec « Chargement » inscrit au milieu. Ça mouline mais n’aboutit jamais.

dans le ficher :
/var/log/scenarichain-server5.0/scstatic_2020-12-04.log
je n’ai que :
1— Info : Fri Dec 04 14:11:18 CET 2020[788] (main) —

Starting SCENARIchain-server 5.0 : SCENARIchain-server 5.0.7 (202007201345) on OpenJDK 64-Bit Server VM 11.0.9 11.0.9+11-post-Debian-1deb10u1 / Linux amd64
1— Info : Fri Dec 04 14:11:18 CET 2020[799] (main) —
OpenDocument editor found by env. var. ‹ PATH › in: /usr/lib/libreoffice/program

Dans /etc/nginx/conf.d/scenari.conf
J’ai précisé comme fichiers de logs :
error_log /var/log/nginx/error_scs_cnam.log error;
access_log /var/log/nginx/access_scs_cnam.log combined;

Mais ces derniers sont vides.

J’ai du commettre une erreur quelque part mais impossible de mettre la main dessus.

Petite question : en passant par l’apt, faut-il changer les fichiers configurant Jetty également ?

Lilian.

Et vous avez quelque-chose dans le console Javascriopt de votre navigateur ?

Bien vu !
Oui j’ai des infos :
Access to script at ‹ http://163.173.128.101:8080/scenarichain-server5.0/~~static/scCore/fr-FR/-wlb/5.0.7.20200720132046/core/universe.js › from origin ‹ http://scs5.cnam.fr:8080 › has been blocked by CORS policy: No ‹ Access-Control-Allow-Origin › header is present on the requested resource.
home.js?1595245523172:15 GET http://163.173.128.101:8080/scenarichain-server5.0/~~static/scCore/fr-FR/-wlb/5.0.7.20200720132046/core/universe.js net::ERR_FAILED
(anonymous) @ home.js?1595245523172:15
(anonymous) @ home.js?1595245523172:15
(anonymous) @ home.js?1595245523172:219
home.js?1595245523172:219 Uncaught (in promise) TypeError: Failed to fetch dynamically imported module: http://163.173.128.101:8080/scenarichain-server5.0/~~static/scCore/fr-FR/-wlb/5.0.7.20200720132046/core/universe.js
async function (async)
(anonymous) @ home.js?1595245523172:8
(anonymous) @ home.js?1595245523172:219
home.xhtml:1 Access to script at ‹ http://163.173.128.101:8080/scenarichain-server5.0/~~static/scCore/fr-FR/-wlb/5.0.7.20200720132046/commons/registry.js › from origin ‹ http://scs5.cnam.fr:8080 › has been blocked by CORS policy: No ‹ Access-Control-Allow-Origin › header is present on the requested resource.
home.js?1595245523172:15 GET http://163.173.128.101:8080/scenarichain-server5.0/~~static/scCore/fr-FR/-wlb/5.0.7.20200720132046/commons/registry.js net::ERR_FAILED
(anonymous) @ home.js?1595245523172:15
(anonymous) @ home.js?1595245523172:15
(anonymous) @ home.js?1595245523172:219
home.xhtml:1 Access to script at ‹ http://163.173.128.101:8080/scenarichain-server5.0/~~static/scCore/fr-FR/-wlb/5.0.7.20200720132046/commons/desk.js › from origin ‹ http://scs5.cnam.fr:8080 › has been blocked by CORS policy: No ‹ Access-Control-Allow-Origin › header is present on the requested resource.
home.js?1595245523172:15 GET http://163.173.128.101:8080/scenarichain-server5.0/~~static/scCore/fr-FR/-wlb/5.0.7.20200720132046/commons/desk.js net::ERR_FAILED
(anonymous) @ home.js?1595245523172:15
(anonymous) @ home.js?1595245523172:15
(anonymous) @ home.js?1595245523172:219
home.xhtml:1 Access to script at ‹ http://163.173.128.101:8080/scenarichain-server5.0/~~static/scCore/fr-FR/-wlb/5.0.7.20200720132046/commons/io/io.js › from origin ‹ http://scs5.cnam.fr:8080 › has been blocked by CORS policy: No ‹ Access-Control-Allow-Origin › header is present on the requested resource.
home.js?1595245523172:15 GET http://163.173.128.101:8080/scenarichain-server5.0/~~static/scCore/fr-FR/-wlb/5.0.7.20200720132046/commons/io/io.js net::ERR_FAILED
(anonymous) @ home.js?1595245523172:15
(anonymous) @ home.js?1595245523172:15
(anonymous) @ home.js?1595245523172:219
home.xhtml:1 Access to script at ‹ http://163.173.128.101:8080/scenarichain-server5.0/~~static/scCore/fr-FR/-wbk/5.0.7.20200720132046/core/appFrame.js › from origin ‹ http://scs5.cnam.fr:8080 › has been blocked by CORS policy: No ‹ Access-Control-Allow-Origin › header is present on the requested resource.
home.js?1595245523172:15 GET http://163.173.128.101:8080/scenarichain-server5.0/~~static/scCore/fr-FR/-wbk/5.0.7.20200720132046/core/appFrame.js net::ERR_FAILED
(anonymous) @ home.js?1595245523172:15
(anonymous) @ home.js?1595245523172:15
(anonymous) @ home.js?1595245523172:219
home.xhtml:1 Access to script at ‹ http://163.173.128.101:8080/scenarichain-server5.0/~~static/scCore/fr-FR/-wbk/5.0.7.20200720132046/core/plugins/optionsPlg.js › from origin ‹ http://scs5.cnam.fr:8080 › has been blocked by CORS policy: No ‹ Access-Control-Allow-Origin › header is present on the requested resource.
home.js?1595245523172:15 GET http://163.173.128.101:8080/scenarichain-server5.0/~~static/scCore/fr-FR/-wbk/5.0.7.20200720132046/core/plugins/optionsPlg.js net::ERR_FAILED
(anonymous) @ home.js?1595245523172:15
(anonymous) @ home.js?1595245523172:15
(anonymous) @ home.js?1595245523172:219

Lilian.

OK, on commence à comprendre !
Donc visiblement vous avez installé SCENARIchain-server mais vous ne lui avez jamais indiqué son URL publique.
c.f. https://doc.scenari.software/SCENARIchain-server@5.0/linux/fr/#$1:configSC_deb:VjIaHrdzNJfbij9b8ObdXi
Vous avez quoi pour webapp.public.url ?
Normalement si vous mettez juste « / » cela devrait marcher, dans ce cas on doit pouvoir utiliser le serveur depuis n’importe-quel URL / IP qui route vers le serveur. Par contre si cette valeur contient une URL de la forme http://mon.server.fr/monApp ou http://192.168.1.100/monApp alors in FAUT utiliser cette URL.

Bonjour,

j’avais précisé l’url en dure :
webapp.public.url=http://scs5.cnam.fr:8080/scenarichain-server5.0
Suite à votre message j’ai modifié en :
webapp.public.url=/scenarichain-server5.0

Mais ça ne fonctionne pas.

J’ai toujours une erreur « has been blocked by CORS policy: No ‹ Access-Control-Allow-Origin › header is present on the requested resource. »

Suivant la doc j ai installé : apt-get install nginx-extras

Et je tente de jouer sur les Access-Control-Allow-Origin sans succès pour le moment :confused:

Lilian.

et vous avez bien reconstruit le war ?
https://doc.scenari.software/SCENARIchain-server@5.0/linux/fr/#$1:configSC_deb:koFsEjeuMbjHoGQTRXc21g

Oui.

Lilian.

Cela fonctionne en http !