Formule LaTeX - Scenari4.2/Opale3.6 sous MacOS 10.11

Bonjour,
La nouvelle version de Scenari 4.2/Opale 3.6 ne permet toujours pas d’interpréter les formules LaTeX dans “l’éditeur en ligne” (par contre l’aperçu avec Aurora fonctionne très bien).
M. Eric Loubignac avait créer un lanceur (évitant d’avoir recours au Terminal et au lancement par ligne de commande) qui fonctionnait très bien avec Scenari 4.1/Opale 3.5 et qu’il mettait gracieusement à la disposition de ceux qui lui en faisait la demande (merci encore à lui). Pourrait-on “officialiser” ce type d’outils et le rendant disponible au téléchargement comme une extension à défaut de l’intégrer dans les versions pour Mac OS ?

Très bonne idée! Cela faciliterait l’installation de Scenari chez les utilisateurs mac.
Katia

Bonjour
je suis fort intéressée aussi par une version du lanceur adapté pour Opale 3.6.
Je ne sais pas si Eric a pris le temps de le faire.
Si oui, merci de partager avec nous le lien pour le récupérer.
Je dois en effet installer Opale 3.6 pour une collègue qui travaille sous Macintosh HD OS X, 10.10.5.
Son cours comporte beaucoup de formules mathématique avec LaTeX. Il y a déjà une version du cours réalisée avec Opale 3.5 sous Windows.
Au cas où le lanceur pour Mac n’est pas disponible, merci de me dire quelle version de java il faut installer et quel éditeur pour les formules mathématiques.
Merci de votre aide
Atika

Bonjour,

Une façon simple de le faire est de lancer l’application Terminal (elle est dans le dossier Utilitaires lui-même étant dans Applications). Saisir le texte ci-dessous :
/Applications/SCENARIchain\ 4.1.app/Contents/MacOS/xulrunner

On suppose que Scenari n’est pas déjà lancé et que l’application s’appelle “SCENARIchain 4.1.app”

Il faut aussi au préalable avoir indiqué le chemin de la jvm dans les paramètres de Scenari. Si tu ne sais pas faire, je te mettrais dans un autre post, ce qu’il faut faire.

A+
Christian

Bonjour Atika,

J’ai fait les modifications nécessaires pour Scenari 4.2 récemment, cela semble fonctionner. Donc pour ceux que cela intéresse, vous pouvez récupérer le lanceur à cette adresse.

Quant à ceux qui ne veulent pas s’embarrasser du lanceur, la solution de Christian fonctionne très bien sauf que que pour Opale 3.6, il faudra plutôt saisir :
/Applications/SCENARIchain\ 4.2.app/Contents/MacOS/SCENARIchain

@ plus,
Éric

Merci Christian,
ce dont j’ai besoin c’est directement Opale 3.6 mais surtout avoir la possibilité de récupérer toutes les formules mathématiques introduites avant avec LaTeX
Merci de m’indiquer dans un post toute la procédure. Mes connaissances en Mac IOS sont très limitées et je n’ai pas beaucoup de temps à investir dans l’installation.
Merci d’avance
Atika

Bonjour Eric,
merci beauoup pour le boulot.
Je vais tester le lanceur.
Est ce qu’un éditeur de formules mathématiques est intégré dans le lanceur ?
A plus
Atika

Non, le lanceur est juste une interface graphique qui te permet de lancer les applications Scenari avec les bonnes variables d’environnement, ce qui permet entre autre à LaTeX de fonctionner correctement dans Opale. Actuellement, si tu lances SCENARIchain directement sur Mac, le visualiseur d’équation LaTeX intégré à Opale ne fonctionne pas.

Ton cours est actuellement sous quel format ?

je dispose des sources développées avec la version Opale 3.5 sous windows.
Je peux si tu veux t’envoyer en privé un chapitre sous format scar pour tester si cela passe.
Merci pour ton aide
Atika

Je viens de télécharger le nouveau lanceur d’Eric Loubignac qui permet, au choix, lancer SCENARIChain 4.1/Opale 3.5 ou bien SCENARIChain 4.2/Opale 3.6. J’ai mis à jour ma distribution LaTeX (TeXlive 2016), j’ai téléchargé et installé SCENARIChain 4.2/Opale 3.6 (les dernières versions disponibles) et j’ai créé une archive .SCAR de mes espaces pour SCENARIChain4.1/Opale 3.5 pour tester sous la dernière versions.
Je constate qu’en utilisant le nouveau lanceur pour lancer SCENARIChain 4.1/Opale 3.5 rien n’est changé par rapport à la version précédente du lanceur et les formules LaTex sont bien interprétées dans l’éditeur et dans l’aperçu.
En lançant SCENARIChain 4.2/Opale 3.6 et en éditant le même grain que précédemment, non seulement les formules LaTeX ne sont pas interprétées mais il n’y a pas plus de prévisualisation de l’image au format .png présente dans ce grain (et en passant sur l’image source dans le menu un X s’affiche), l’aperçu web aurora interprète bien les formules LaTeX mais ignore complètement la présence de l’image. En vérifiant par survol sur mes images, aucune n’est prévisualisée (.png, .jpeg. gif) que ce soit en désignant la version embarquée d’ImageMagicK ou par défaut du système.
Bref je reste sur SCENARIChain 4.1/Opale 3.5 en attendant mieux…

Je viens de trouver la solution en parcourant le forum… J’ai supprimé les accents dans le nom de tous mes espaces et sous-espaces et miracle, LaTeX est interprété et les images ont refait leur apparition…
Merci tout de même à Eric de nous avoir fourni un nouveau lanceur pour les MacUsers.

Bonjour Anika,

Concernant latex et le mac, voici quelques infos.
De mémoire, il faut installer le pack MacTek que tu peux récupérer à l’adresse https://tug.org/mactex/mactex-download.html
Une fois le racket récupérer fais un double-clic sur lai paquet récupéré et laisse toi guider.

Ensuite il est nécessaire d’indiquer à scenarichain où trouver la machine virtuelle java. Je suppose que java est déjà présent sur le poste. Pour cela, une fois que tu as lancé ScenariChain, tu appuies sur les touches cmd+majuscule+k
là tu entres dans une zone dangereuse, il ne faut pas faire n’importe quoi. Clique sur le bouton “je ferai attention”.
Une fenêtre s’affiche avec un champ de saisie en haut. Tapes jvm
en dessous tu peux voir une ligne scenari.jvm.path

Si tu ne la vois, ce n’est pas grave il faut la créer : fais un clic droit sous la liste affichée. Tu dois voir un menu avec “nouvelle”, choisi “chaine de caractères”. On te demande alors de donner le nom de l’option, tapes : scenari.jvm.path
ensuite on te demande de saisir une nouvelle valeur. Saisie alors :
/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Commands/java

Si tu la vois : fais un double clic dessus et entre la chaine :
/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Commands/java

la chaine “/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Commands/java” indique où on peut trouver la machine virtuelle java sur ton mac. Tout dépend de la version que tu as, mais si c’est la dernière, elle doit être correcte.

Ensuite, ferme la fenêtre. Quitte et relance ScenariChain.

Voilà, normalement latex doit marcher modulo la façon particulière de lancer ScenariChain comme indiqué dans un autre post.

bien à toi
Christian

Bonjour,
ATTENTION : pa partie sur Java ci-dessus ceci est totalement faux en SCENARI 4.2 qui EMBARQUE sa version de Java, comme sous Windows. De plus SCENARI 4.2 n’est absolument PAS compatible avec Java 6.

Bonsoir,
Merci pour l’info. Je retarde un peu car je suis en 4.1 Désolé d’avoir apporté une mauvaise solution.
Christian

merci pour vos réactions.
C’est la semaine prochaine que je vais faire l’installation. J’espère m’en sortir.
Encore merci pour l’intérêt

Bonjour
mes formules ne sont pas interprétées dans l’éditeur Opale.
C’est FixMacTex2014.pkg qui est installé
Quel chemin faudrait-il spécifier et où ??
Merci de votre aide

Bonjour,

FixMacTex n'est pas une distribution LaTeX... il faut tout de même
installer MacTex :

https://tug.org/mactex/

Fabien.

Merci Fabien
Les deux ont été installés.
Le problème c’est d indiquer à scenari où cela se trouve.
Une fiche complète d’installation par type d’os serair franchement la bienvenue.
Moi je veux me charger de Windows mais le monde Mac reste encore un mystère pour moi.
Merci pour vos réactions
Atika

Bonjour Atika,

Il n'est pas possible d'indiquer à Scenari où se trouve LaTeX...
mais il faut faire en sorte qu'il le sache !




Donc; deux solutions (que je rappelle ici, même si Eric l'a déjà dit
dans son précédent message sur le sujet...) :

1- à partir d’un terminal, tu lances ScenariChain … et il
retrouvera tout seul LaTeX en se basant sur les variables
d’environnement. Pour cela, lances Scenari en indiquant le chemin
vers l’exécutable :

    <tt>/Applications/SCENARIchain\
  4.2.app/Contents/MacOS/SCENARIchain</tt>




Tu peux vérifier avant que ton latex est bien installé, en tapant
par exemple la commande :

which pdflatex

qui doit te répondre quelque chose du genre :

/Library/TeX/texbin/pdflatex

2- Utilises le lanceur proposé par Eric, qui règle le
problème, sans devoir passer par un terminal

à+,


Fabien.

Merci Fabien pour ces précisions.
Je testerai les pistes
A+
Atika