Erreur d'authentification SCENARI

Bonjour,
Je viens chercher de l’aide ou bien même des informations concernant un problème que nous avons rencontré ce vendredi 15/01/2021. J’ai effectué un redémarrage d’un serveur local suite à ce redémarrage, une erreur survient concernant l’authentification.
" Le système d’authentification est indisponible. Veuillez vous connecter ultérieurement"
Aujourd’hui, lundi 18/01/2021, le problème persiste encore, après plusieurs heures passées sur ce problème nous sommes à court d’idées.
La moindre information peut être nécessaire pour nous sortir de cette impasse.
Merci d’avance,

Un problème de réseau (parefeu qui bloque ?),
ou bien de certificat invalide sur le serveur :

Dans la console de l’application directement (CTRL+MAJ+J) nous avons comme erreur :

Horodatage : 18/01/2021 14:49:25
Erreur : Une erreur est survenue pendant une connexion à x.x.x.x:8090.
SSL a reçu un enregistrement qui dépasse la longueur maximale autorisée.
(Code d’erreur : ssl_error_rx_record_too_long)

Lorsque nous tapons notre adresse IP suivit du port nous sommes bien redirigés vers la page d’accueil de Tomcatt.

Mais lorsque nous indiquons l’url complète suivante :

x.x.x.x:8090/scchainsrv50
Nous avons une erreur 404 :

État HTTP 404 – Non trouvé

Type Rapport d’état
message La ressource demandée [/scchainsrv50] n’est pas disponible
description La ressource demandée n’est pas disponible.

Apache Tomcat/9.0.40

il peut y avoir d’autres cas d’erreur ponctuelle, comme celui-là :

Le pare-feu a bien été vérifié cependant concernant les certificats, je ne m’y connais pas du tout. Comment vérifier cela?
Comment l’enlever ? Est-il indispensable ?

Bonjour,

Avez-vous consulté le fichier de log de l’application (https://doc.scenari.software/SCENARIchain-server@5.0/linux/fr/#$0:configSc_generic:DrZNH1UD8oeVxIaQGgztHf) ?

Cdt,
Antoine
Kelis

Concernant les logs, le message suivant :
1— Info : Mon Jan 18 14:11:42 CET 2021[675] (main) —

Starting SCENARIchain-server 5.0 : SCENARIchain-server 5.0.7 (202007151901) on Java HotSpot™ 64-Bit Server VM 1.8.0_261 25.261-b12 / Windows Server 2012 R2 amd64
1— Info : Mon Jan 18 14:11:42 CET 2021[792] (main) —
OpenDocument editor defined by env. var. ‹ UNO_PATH › in: C:\Program Files\LibreOffice\program

C’est le seul contenu dans le fichier de log ?

Oui, enfin il est répété plusieurs fois dans le fichier.

Cela ne viendrait pas de Tomcat ?
Quand je met le .war dans le dossier webapps de Tomcat 9 et que lance tomcat le dossier scchainsrv50 est bien crée cependant les liens du fichier session.txt du dossier « _ testing _ » affiche uniquement des erreur 404.

Vous avez regardé dans les logs Tomcat ?

Quand vous avez effectué le redémarrage de votre serveur Windows, vous avez bien arrêté Tomcat avant le redémarrage ? Tomcat a bien eu le temps de s’arrêter correctement ?

TomCat n’a pas été arrêté avant le redémarrage du serveur cependant pour ce qui est des logs du fichier localhost nous avons cela :

19-Jan-2021 08:34:37.804 GRAVE [main] org.apache.catalina.core.StandardContext.listenerStart Exception lors de l’envoi de l’évènement contexte initialisé (context initialized) à l’instance de classe d’écoute (listener) [eu.scenari.core.execframe.httpservlet.servlets.InitAppContextListener]
java.lang.NoClassDefFoundError: com/sun/star/lang/XEventListener
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)

Et pour les logs du fichier TomCat je vous joins le fichier source :
tomcat9-stderr.2021-01-19.log (65,0 Ko)

au vu des logs il semble que la configuration du classLoader de Tomcat soit pas au top (https://doc.scenari.software/SCENARIchain-server@5.0/windows/fr/#tomcat_win_1:Dr8QNqtLRRiXMHCtRcKFRd)

Mon chemin d’accès est C:/Programmes/LibreOffice/program/classes/

Cependant, dans mon Program Files(x86) mon dossier LibreOffice n’y est pas présent.

Après modification, je viens de m’apercevoir que les classes demandées ne sont pas présentes dans mon dossier classes est-ce normal?

Dans mon dossier classes, il n’y a pas le jurt.jar,ridl.jar ni unoil.jar

Je ne comprends pas bien, Vous avez installé LibreOffice ? si oui quelle version et ou ?

Sur l’ordinateur je possède juste un dossier Program Files(x86) et un autre nommé Programmes

Dans ce dossier Programmes se trouve mon dossier libreoffice

Si LibreOffice est installé dans C:/Program File(x86)/LibreOffice/ pourquoi vous parlez de C:/Program Files/LibreOffice ?

Bonjour,
Pour info, je viens de faire une nouvelle installation de LibreOffice 6.4.7.2 (x64)
J’ai bien les 4 jars mentionnés dans C:\Program Files\LibreOffice\program\classes.
Retentez l’installation de LibreOffice après un redémarrage ?