Webmedia 3 - Pas de segmenteur


#1

Bonjour,

je viens d’installer scenariCchain 4.2.1.06-final (201801312141)
avec le pack “webMedia3-0_fr-FR_004_201712011455_sc42.wsppack”.

Je suis sous Ubuntu GNU/Linux.

Il m’est impossible d’obtenir le segmenteur.
Il reste bloquer sur “Chargement du media et de l’interface en cours, veuillez patienter …”
J’ai essayé avec du webm et du mp4, cela ne change rien.

S’agit-il d’un bug ou est-ce que j’oublie quelque chose ?

En vous remerciant,

Jérémie


#2

Bonjour,

Vous êtes sous quelle version de Ubuntu et vous avez installé SCENARI comment ?


#3

Bonjour,
j’utilise la dernière version d’Ubuntu GNU/Linux. La 18.04.
J’ai installé via la méthode Ubuntu/Debian en récupérant le dépôt sur le site scenari.


Ajouter le dépôt SCENARI en ligne de commande :
echo “deb https://download.scenari.org/deb lsb_release -sc main” | sudo tee -a /etc/apt/sources.list.d/scenari.list
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com C1B92A9981DBBE62
sudo apt update
Pour installer l’application en français :
sudo apt install scenarichain4.2.fr-fr


Puis j’ai téléchargé le pack webmedia3.

Merci,

Jérémie


#4

Et si vous lancez SCENARIchain en linge de commande, vous avez des erreurs dans votre terminal ?


#5

user@ubuntu-pc:~$ scenarichain4.2
2018-07-16 10:36:45.468:INFO::main: Logging initialized @63ms
2018-07-16 10:36:45.575:INFO:esjs.Server:main: jetty-9.1.4
2018-07-16 10:36:45.757:INFO:esjsh.ContextHandler:main: Started e.s.j.s.ServletContextHandler@184cf7cf{/,null,AVAILABLE}
2018-07-16 10:36:45.765:INFO:esjs.ServerConnector:main: Started ServerConnector@4278a03f{HTTP/1.1}{127.0.0.1:35105}
2018-07-16 10:36:45.766:INFO:esjs.Server:main: Started @387ms
2018-07-16 10:36:53: basic_code_modules.cc:70: ERROR: Module /usr/lib/libscenarixul4.2/libmozsqlite3.so could not be stored
2018-07-16 10:36:53: basic_code_modules.cc:70: ERROR: Module /usr/lib/libscenarixul4.2/liblgpllibs.so could not be stored


#6

Tout ça c’est normal, rien quand vous tentez de créer un nouveau segmenteur ?


#7

Aucun changement.

Lorsque je place la vidéo dans le fichier.seg, il ne la détecte pas automatiquement qu’un média a été ajouté.
Je dois recharger la page pour qu’il commence a afficher :
“Chargement du media et de l’interface en cours, veuillez patienter …”

Jérémie


#8

Quand je place une vidéo :

1— Error : Mon Jul 16 11:31:59 CEST 2018[410] - chain/ (qtp1225358173-15) —
Send dialog result failed for : Dialogue du service=[Svc:wspSrc]; Class=eu.scenari.wsp.service.wspsrc.SvcWspSrcDialog

2— Error : Mon Jul 16 11:31:59 CEST 2018[410] - chain/ (qtp1225358173-15) —
Send result failed : eu.scenari.wsp.service.wspsrc.SvcWspSrcSender

3— Error : Mon Jul 16 11:31:59 CEST 2018[410] - chain/ (qtp1225358173-15) —
Echec à la transformation ‘transform=ffmpeg&outFormat=json&outType=PROPS’ sur l’item

4— Error : Mon Jul 16 11:31:59 CEST 2018[410] - chain/ (qtp1225358173-15) —
FFmpeg processing failed:
avconv -i /home/pilette/SCchain4.2/MaterniteGrossesse/sources/videos/MVI_0394.MP4/MVI_0394.MP4

5— Exception : Mon Jul 16 11:31:59 CEST 2018[410] - chain/ (qtp1225358173-15) —
Cannot run program “avconv”: error=2, Aucun fichier ou dossier de ce type
java.io.IOException: Cannot run program “avconv”: error=2, Aucun fichier ou dossier de ce type
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
at eu.scenari.transform.ffmpeg.FFmpeg.callFfmpeg(FFmpeg.java:126)
at eu.scenari.transform.ffmpeg.FFmpeg.getInfo(FFmpeg.java:151)
at eu.scenari.transform.ffmpeg.TfmFFmpeg.transform(TfmFFmpeg.java:115)
at com.scenari.m.bdp.item.fs.XItemCacheData.transformAsStream(XItemCacheData.java:475)
at com.scenari.m.bdp.item.fs.XItemCacheData.transformAsNode(XItemCacheData.java:522)
at com.scenari.m.bdp.item.fs.WspSrcNodeItem.transformAsNode(WspSrcNodeItem.java:915)
at com.scenari.src.feature.transform.SrcFeatureTransform.transformAsNode(SrcFeatureTransform.java:133)
at eu.scenari.wsp.service.wspsrc.SvcWspSrcSender.xSendDialogResult(SvcWspSrcSender.java:419)
at eu.scenari.core.execframe.httpservlet.SenderHttpResponseBase.sendDialogResult(SenderHttpResponseBase.java:74)
at eu.scenari.core.execframe.httpservlet.reqconn.HttpRequestConnectorApi.sendResponse(HttpRequestConnectorApi.java:130)
at eu.scenari.wsp.execframe.HttpRequestConnectorUiMoz.sendResponse(HttpRequestConnectorUiMoz.java:181)
at eu.scenari.core.execframe.httpservlet.HttpRequestConnectorBase.handleRequest(HttpRequestConnectorBase.java:77)
at eu.scenari.core.execframe.httpservlet.servlets.ServiceServlet.service(ServiceServlet.java:159)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
at eu.scenari.jetty.servlet.ServletHolder.handle(ServletHolder.java:738)
at eu.scenari.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:551)
at eu.scenari.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1111)
at eu.scenari.jetty.servlet.ServletHandler.doScope(ServletHandler.java:478)
at eu.scenari.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1045)
at eu.scenari.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
at eu.scenari.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
at eu.scenari.jetty.server.Server.handle(Server.java:462)
at eu.scenari.jetty.server.HttpChannel.handle(HttpChannel.java:279)
at eu.scenari.jetty.server.HttpConnection.onFillable(HttpConnection.java:232)
at eu.scenari.jetty.io.AbstractConnection$1.run(AbstractConnection.java:534)
at eu.scenari.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:607)
at eu.scenari.jetty.util.thread.QueuedThreadPool$1.run(QueuedThreadPool.java:536)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.io.IOException: error=2, Aucun fichier ou dossier de ce type
at java.lang.UNIXProcess.forkAndExec(Native Method)
at java.lang.UNIXProcess.(UNIXProcess.java:247)
at java.lang.ProcessImpl.start(ProcessImpl.java:134)
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
… 28 more


#9

Bizarre… que vous donne la commande :
apt -a show libscenarisrv4.2


#10

bon, j’ai compris. Je regarde.


#11

user@ubuntu-pc:~$ apt -a show libscenarisrv4.2
Package: libscenarisrv4.2
Version: 4.2.106-s2
Priority: optional
Section: libraries
Maintainer: scenari-platform info@scenari-platform.org
Installed-Size: 9 519 kB
Depends: openjdk-7-jre | openjdk-8-jre | oracle-java7-installer | oracle-java8-installer, imagemagick, fontconfig, ffmpeg
Recommends: libreoffice
Suggests: msttcorefonts
Download-Size: 8 621 kB
APT-Manual-Installed: no
APT-Sources: https://download.scenari.org/deb bionic/main amd64 Packages
Description: SCENARI 4.2 server library
This library is a dependence of all stand-alone SCENARI applications.
.
SCENARI is an open source application suite for designing publishing chains
used for creating professional multimedia documents.
A publishing chain is a technological and methodological process which is the
result of document engineering research. The publishing chain approach is to
design a document model to make content creation easier and to automate
formatting.
.
For more information visit http://scenari-platform.org
.
This package was built on 180502-1730.


#12

Bonjour Samuel,
est-ce un problème sur ma machine ou quelque chose à corriger dans le logiciel?
En te remerciant,
Jérémie


#13

Le problème est avec les deb stables actuellement sur le dépôt qui ne sont pas compatibles avec Ubuntu 18.04. En attendant que ce problème soit résolu, vous pouvez activer les versions nightly en modifiant votre fichier /etc/apt/sources.list.d/scenari.list et en ajoutant “nightly” à la fin de la ligne deb
puis sudo apt update; sudo apt upgrade


#14

Bonjour Samuel,
merci pour l’information.
Je viens d’installer Webmedia3 sur mon Ubuntu GNU/Linux 18.04 avec le .tar.gz.
Le segmenteur fonctionne, cependant c’est maintenant les images qui ne s’affichent pas.

Je dois maintenant tester avec le dépôt Nightly.
Jérémieerreur_export-webmedia3.pdf (69,3 Ko)


#15

pourquoi en tgz ? Passez en nightly tout simplement non ?


#16

sinon pour la transformation des images depuis une version tgz sous Ubuntu 18.04, vous pouvez passer à l’usage de la version OS de ImageMagick :
image


#17

Je voulais essayer l’installation différente.
Je suis passé en Nightly.
Cela semble fonctionner (Images + segmenteur).

Merci pour vos réponses rapides.

Jérémie