Video embarquée

Bonjour,
J’ai inséré une video dans un étape avec les paramètres <iframe height=« 315 » width=« 516 »…
Quand je regarde le « embed code » de la publication cela devient <iframe width=« 700 » height=« 1565 »…
C’est un peu (beaucoup) embêtant.

Vous parlez d’un fragment HTML non ?

Oui, une iframe qui contient une video Youtube en utilisant l’item "Module Web Distant (fragment HTML) pour être très précis.
Je pourrai la mettre en dur mais cela m’allège le module (web ou scorm).

Bonjour,
Je connais le même problème avec Topaze 1.6, avec une vidéo embarquée ainsi qu’un iframe d’un autre site (genially). Tout fonctionnait très bien avec la version précédente de Topaze, mais là, même en inscrivant dans l’iframe les valeurs width et height de mon choix, il les remodifie à la génération. Le contenu distant apparaît donc sur environ la moitié gauche de mon écran et se superpose aux balises en-dessous s’il y en a… Plutôt gênant…
Si quelqu’un a une solution je suis preneuse ^^’

Que la génération recalcule les paramètres « height » et « width » pourquoi pas, ça rempli l’espace disponible.
Ce qui m’étonne : « height » est plus grand que « width » comme s’il y avait inversion entre les deux paramètres…

Oui peut-être que ces 2 critères sont inversés… Mais cela me semble peu probable car parfois la hauteur est vraiment importante comme on peut le voir ci-dessous.
Est-ce que quelqu’un de chez Kelis (ou quelqu’un d’autre !) a une idée pour résoudre ce problème ? Car le rendu est vraiment problématique :worried:
Exemple d’une vidéo :

!

Exemple d’un genially - haut de page :

Bas de page :

(Le rendu est le même avec l’habillage standard, ce n’est donc pas ma charte graphique qui pose problème)

Le problème est aussi présent avec des vidéos en dur et pas qu’avec des iframes…

Hello Gaëlle,
J’ai corrigé une petite anomalie sur ce sujet, mais pas sur que ça résolve ton pb :slight_smile:
Pour vérifier, tu peux utiliser un pack nighty de Topaze 1.6 : https://builds.kelis.fr/job/pack-Topaze-1.6-sc50/.
Si le pb persiste, tu pourras donner un contenu minimaliste permettant de le reproduire, et on y regardera ?
Antoine

Bonjour Antoine,
Merci de ton aide, j’ai testé, mais j’ai toujours le même résultat. Je t’envoie un scar avec le contenu minimaliste. Par contre @pjacob je n’ai pas le problème avec une vidéo locale.

Bonjour
Le problème a été corrigé et est disponible dans la dernière nightly.
Cordialement,
Nicolas

1 J'aime

Bonjour,
En effet, c’est parfait pour les vidéos… mais voilà ce que donne un site Web embarqué :
Coté éditeur :
image

Rendu :