Transcodage, compteur et bande son avec WM 2.4

Bonjour,
j’avais l’habitude d’utiliser Webmedia2 avec ScenariChain 4.1 et je suis passé sur :

  • ScenariChain 4.2.1.03 et
  • Webmedia 2.4.005

Je rencontre plusieurs difficultés sous cette nouvelle configuration :

  • lorsque je lance le transcodage d’une vidéo, celui-ci “tourne” indéfiniment sans aboutir ;
  • lorsque j’intègre la vidéo dans un item “segmentation”, il est possible de la lire normalement, mais :
  • il est impossible de configurer le compteur à une valeur particulière (toute action renvoie le curseur d’écriture après la dernière décimale du comptage, qui ne change pas)
  • le chronogramme de la bande son ne s’affiche pas (ce qui est dommage car c’est bien pratique pour la segmentation)

J’ai essayé sur plusieurs ordinateurs (tous sous windows 7 il est vrai), avec plusieurs vidéos (toutes en mp4 il est vrai).
Les vidéos testés sont de courtes durées (inférieures à 5 mn), les noms donnés au sein de WM ont moins de 10 caractères, et ne comportent pas de caractères spéciaux.

Merci de votre aide

Bonjour,
pas de réponses… peut être faut il poser la question autrement.

Pourrais je avoir des retours d’expériences avec ScenariChain 4.2 et Webmedia 2.4, d’utilisateurs pour qui ça fonctionnerait sans problème ? et avec quel système d’exploitation ?

De mon côté j’ai essayé en modifiant le format de la vidéo (avec Format Factory) de mp4 à webm sans résultats probants.
J’ai l’impression d’un fonctionnement aléatoire : le transcodage aboutit au bout de plusieurs heures, les chronogrammes de la bande son finissent parfois par apparaître, et à partir de ce moment le réglage du compteur devient “parfois” possible, sans que je sache ce qui fait que ça fonctionne ou pas.

J’ai refait des tests avec Scenari 4.1 (sur le même ordi, W7, Firefox 52), et je ne rencontre aucune difficulté.

Merci de votre aide

Bonjour,

J’ai fait un test d’encodage sous Mac et la même config ScenariChain 4.2.1.03 et Webmedia 2.4.005 à partir d’un fichier mp4 de deux minutes environ généré avec Quicktime ( H264, AAC)

Le fichier OGG Theora est encodé sans problèmes,on peut le consulter, on peut le segmenter à partir du compteur et la forme d’onde est affichée.
Le fichier WEBM est encodé ,on peut le consulter , mais il n’apparaît pas dans la segmentation. Pas de forme d’onde affichée.
Un transcodage MP4 fonctionne aussi, segmentation et affichage forme d’onde ok.

Pour des vidéos plus longues, j’ai pris l’habitude de segmenter à partir d’un transcodage audio puis de forcer la vidéo à la publication. (Le transcodage de longues vidéos prenant des heures …) Mais pour des petites durées 5 mnn cela devrait passer ?

Dominique

Bonjour à tous,

Concernant le transcodage interne à WebMedia, suivant les OS, l’utilitaire utilisé (ffmpeg) peut être soit celui de votre système (linux), soit celui embarqué dans l’application (windows et mac).
Pour les utilisateurs de debian et ubuntu, l’encodage WebM par défaut est désormais en vp9, format qui n’est pas supporté par l’éditeur Scenari.

Il est par ailleurs déconseillé de transcoder de grandes vidéos. L’éditeur actuel n’étant pas optimisé pour afficher, traiter et naviguer dans de grands fichiers vidéos.
L’un des workaround “connu” consiste, comme le propose Dominique, à travailler avec la piste audio en édition et à lier le fichier vidéo uniquement pour la publication.

A noter que nous sommes actuellement sur un chantier de refonte conséquent de WM avec notamment une remise à plat de la gestion des différents formats en édition et en publication.
Plus d’infos normalement d’ici mi-fin Avril…

Bonne journée
Ludovic

Bonjour à tous,
merci pour ces retours.

Au vu des expériences décrites, je pense que pour l’instant il est plus sage de continuer avec ScenariChain 4.1, et attendre fin avril pour voir ce qui sortira (j’envisage d’animer une séquence de formation autour de l’utilisation de WM, et je ne peux me permettre un fonctionnement que je ne maîtrise pas).

Par contre, je ne comprends pas très bien la méthode, pour les vidéos longues, consistant à segmenter la piste audio, puis lier la vidéo pour la publication.
Prenons un cas concret :

    • je récupère une vidéo sur youtube, que je charge sur mon ordinateur, elle est au format mp4
    • je l’importe dans Webmedia (clic droit “importer”) ;
    • sur l’onglet “Trans” de l’item, je sélectionne “Transcodage audio”,
    • je choisis un des 2 formats, puis “Générer”, puis “Coller”
    • j’ai maintenant un item “monFichier.oga” (suivant le choix précédent) que je glisse dans le champ “média” d’un item “segmentation”
    • je segmente (a ce stade je n’ai pas la forme d’onde affichée, mais elle arrive “parfois” plus tard avec SC 4.2)

Comment je lie maintenant au fichier vidéo d’origine ?

Bonne journée

Bonjour,

Pour compléter les éléments de réponse précédents :
Concernant l’encodage en Webm, le dernier WM encode en vp9/opus qui finalement n’est pas correctement supporté par le moteur XUL de Scenari.
De plus l’encodage d’un Webm vp9 est extrèmement lent…

Il est donc fortement conseillé d’utiliser le format mp4 (H264/AAC) transcodé soit via l’onglet transcodage, soit depuis un outil tiers externe.

A noter que désormais tous les principaux navigateurs supportent nativement le mp4.

Pour la problématique de lier un fichier vidéo à la publication dans un item audio en édition.
Il suffit d’aller dans les proprétés de l’item audio puis "Autre format"
Lors de la publication, le média déclaré ici sera automatiquement sélectionné à la place du média d’"édition"
Cf la documentation : https://archives.scenari.org/projects/webmedia/doc/2.4.x/#nM0JYr8cZjenEKq3RpE86h

Bonne journée

Bonjour,
merci pour ces compléments d’informations.

Concernant la vidéo longue, j’ai donc opéré de la manière suivante :

  1. je récupère une vidéo sur youtube, que je charge sur mon ordinateur, elle est au format mp4
  2. je l’importe dans Webmedia (clic droit “importer”) ;
  3. sur l’onglet “Trans” de l’item, je sélectionne “Transcodage audio”,
  4. je choisis un des 2 formats, puis “Générer”, puis “Coller”
  5. j’ai maintenant un item “monFichier.oga” (suivant le choix précédent) et dans ses propriétés, je glisse mon item mp4 dans le champ "Autres formats"
    6 je glisse l’item audio dans le champ “média” d’un item “segmentation”
  6. je segmente
  7. je glisse le segment dans un item “séquence”, je publie en format web (“Générer”) et visualise (“Consulter”)

A ce stade, je n’ai que la partie audio dans la page qui s’ouvre dans le navigateur…
Ai je oublié une étape ?

Bonne journée