Suprimer le mot exercice dans titre

Bonjour,

Comment peut-on supprimer le mot exercice qui s’affiche dans chaque titre d’un exercice rédactionnel ?

Merci

Bonjour,

Je vous renvoie vers l’ancien forum où cette question avait déjà été posée (et résolue)
http://scenari-platform.org/forum/viewtopic.php?t=4988&highlight=supprimer+exercice

Cordialement

Bonjour,

Merci Bruno, j’ai pu supprimer le mot exercice devant les items concernés.

Oups !
Je reviens sur mon problème du mot “exercice” qui n’est pas résolu, car je viens de m’apercevoir que le modèle Opale que j’ai modifié ne permet plus la création des items activités et autres exercices.
Je ne trouve pas comment dériver une version d’opale qui soit opérationnelle.
Serait-il possible qu’un spécialiste mette en ligne une version d’opale sans ce mot “exercice” .
Dans la foulée pourquoi ne pas rajouter les lettres grecs qui manquent pour les scientifique, comme l’avait fait Bruno dans technopale.
Merci

Bernard,

il faut travailler avec technopale comme ça tu as tout ce que tu demandes (titre exercice retiré et lettres grecques supplémentaires), dans la dernière version tu peux publier soit avec le style technopale soit avec le style opale.
Sinon tu peux prendre les sources de technopale et copier les fichiers qui concerne les exercices (modèle et transformateur) pour ta version, à moins que la version de technopale soit trop loin de celle que tu envisage.
Si tu continu dans ta dérivation il vaudrait mieux poster tes demandes dans la rubrique scenaribuilder pour trouver les “spécialistes”

Bruno,

J’ai la dernière version de technopale et devant le titre d’un exercice rédactionnel, j’ai toujours le mot “exercice”.
Je ne comprends pas où est le bug !

Bonsoir,

Je n’ai pas le mot exercice ni dans un module technopale ni dans un classeur numérique,
Il faut en revanche remplir le titre accroche tout en haut de l’item sinon effectivement le mot exercice remplacera ce champ vide.

Bonjour,
Je viens de constater qu’effectivement le mot “exercice” n’apparaît pas devant le titre d’un exercice rédactionnel si celui-ci est inclus dans un conteneur du type division ou activité.
Par contre il est présent si l’exercice est situé à la racine du document.
C’est surprenant !

Bonjour,

Je ne comprends pas le problème car pour ma part je ne voies pas le mot exercice quelque soit l’endroit (copie d’écran publication et item)

Peux-tu m’envoyer le scar (sous technopale) car je n’arrive pas à créer l’erreur ? c’est bête hein !

Bonjour,

Pour info en Opale 3.6 il sera possible de désactiver le “préfixage” des titres des exercices dans le plan simplement à travers une propriété de génération à modifier dans le fichier ~options/init.properties du skin (prefix.exercise.title-skin=true/false).

Cette option sera disponible dans les générations Web et Diaporama.

1 J'aime

excellente idée… ça fait assez longtemps que cet mention “exercice” m’agace dans certaines utilisations, certes un peu border line, des item “exercices rédactionnels” sous Opale, en particulier avec les générations directe GenPdf…Merci…

Bonjour,
Votre réponse est intéressante, pouvez-vous me donner plus de précision. Comment arriver à cette option car sur opale /édition je ne trouve pas.

Merci d’avance.

Bonjour,
En effet ce n’est pas une option visible, elle fait partie de la configuration du skin de publication. Cette option n’est donc accessible que pour ceux qui produisent leur propre habillage graphique avec SCENARIstyler.

Bonjour,

Merci pour votre réponse. Il faut donc télécharger SCENARIsyler pour pouvoir procéder aux modifications.
Je travaille en collaboration avec un informaticien, lui il pourra accéder à ce genre de données.
Merci encore.

Bonjour,
j’ai rencontré le même problème sur Opale 3.8 j’ai changé exercice en tâche mais ça ne passe pas.

Pouvez-vous nous en dire plus ? je ne comprends pas bien votre problème ni ce que vous voulez dire par cette phrase?

Bonjour
En faites je voudrais changer le nom exercice en tâche sur opale

Bonjour,
Je crois qu’il faut aller dans Builder pour changer les intitulés comme « Exercice » en « Tâche »

Bonjour,
Je suis allez sur builder mais les changements que je faisais concernaient la partie édition.
En mode prévisualisation web le mot exercice est automatiquement généré avant le titre

c’est ce mot (exercice) que je veux remplacer par tâche

Bonjour
Il est possible de supprimer ce mot via styler ou builder en utilisant le fichier init.properties du dossier ~options avec
prefix.exercise.title-skin=false

Pour le changer effectivement il faut passer par Builder dans : /aurora/web/transf/Uc/quiz@nav/quiz@nav.transf
En modifiant :

<sm:fullTitleText>
		<sm:choose>
			<sm:when xpath="op:exeM/sp:title">
				<sm:choose>
					<sm:when xpath="genProp('prefix.exercise.title-skin', 'true')='true'">
						<sm:fixedString value=";Exercice :"/>
						<sm:fixedString value=" "/>
					</sm:when>
				</sm:choose>
				<sm:callModel view="fullTitleText">
					<sm:current/>
				</sm:callModel>
			</sm:when>
			<sm:otherwise>
				<sm:fixedString value=";Exercice"/>
			</sm:otherwise>
		</sm:choose>
	</sm:fullTitleText>

par

<sm:fullTitleText>
		<sm:choose>
			<sm:when xpath="op:exeM/sp:title">
				<sm:choose>
					<sm:when xpath="genProp('prefix.exercise.title-skin', 'true')='true'">
						<sm:fixedString value=";Tâche :"/>
						<sm:fixedString value=" "/>
					</sm:when>
				</sm:choose>
				<sm:callModel view="fullTitleText">
					<sm:current/>
				</sm:callModel>
			</sm:when>
			<sm:otherwise>
				<sm:fixedString value=";Tâche "/>
			</sm:otherwise>
		</sm:choose>
	</sm:fullTitleText>

Cordialement,
Nicolas

1 J'aime