Scenari 5 Serveur - Jetty 9 - configuration SSL

Bonjour,

Jetty est recommandé au lieu de Tomcat pour la version Scenari server 5. Après avoir effectué l’installation et paramètré Scenari (suivie de reconfig) et tenté de paramétrer Jetty 9 pour utiliser le SSL (HTTPS) l’écran d’acceuil Scenari est bien affiché mais au moment du login un message d’erreur apparaît pour une indisponibilité du système d’authentification.
J’utiliser un keystore avec un certificat wildcard, et les pages d’acceuil en 8443 pour Jetty fonctionne, Google Chrome valide parfaitement le certificat également.

Quelqu’un dispose t’il(elle) d’une configuration Jetty qui fonctionne en HTTPS ? La documentation en ligne de Jetty9 est assez … bizarre et la doc de déploiement Scenari ne couvre que le HTTP.

Merci d’avance

Yves

Bonjour,

En général nous ne configurons pas SSL au niveau de Jetty mais au niveau d’un serveur Nginx en frontale.

Merci.

J’ai donc suivi les consignes qui décrivent la procédure décrite sur la documentation en ligne pour configurer NginX

Mais elle correspond à la version compilée (utilisation de scchainsrv50 au lieu de scenarichain-server5.0 pour l’installation debian)

Cela tourne mais redirige vers la version http directement lorsque l’on fait la réquête https.

N’y a t’il pas quelque chose à changer dans les site-available ou sites-enabled de manière à définir le chemin d’accès aux conteny jetty ?

Quelqu’un aurait il un fichier (ou un set de fichiers) types pour la configuration nginx ?
Dans ce cas, la configuration de la webapp est à paramétrer sur quel addresse IP ?

Merci :wink:

Avez-vous bien adapté le paramètre webapp.public.url dans le fichier /etc/scenarichain-server5.0/conf/webapp.properties pour inclure https:// ? (puis un scenarichain-server5.0-cfg reconfig)

En effet :wink: … Merci.

A présent le système est accessible en HTTPS tant par le browser Chrome que par le client lourd. (on progresse)

Les ateliers importés de 4.2 sont bien convertis en 5.0 en ayant suivi la procédure. Cependant, aucun des modèles ou skin n’a été transféré dans le backup des datas.

La gestion des utilisateurs fonctionne et je me suis placé en gestionnaire technique

J’essaye à présent d’installer les modèles Topaze et Opale les plus récents, et ils ne s’installent pas, le message d’erreur ressemble à un fichier trop large mais c’est le cas pour tous les fichiers, même une skin. Tant par mon propre identifiant que par superadmin, et que par Chrome ou par le client lourd

La solution semble d’être l’ajout d’une ligne client_max_body_size 2G; dans le fichier scenari.conf de NGINX

Ou tout simplement client_max_body_size 0; pour supprimer la limite.

1 J'aime

Merci pour l’assistance. Le serveur tourne à présent comme une horloge :slight_smile: