[Résolu]Problème d'acces au menu atelier dans scenari chain 4.2


#1

Bonjour,

Je passe de la version 4.1 à la version 4.2.
Or dans la 4.2, dans l’onglet Atelier, je n’ai plus accès à aucun sous menu “ajouter - installer - propriété - recharger”.

Il n’y a rien, que du blanc,

Est-ce arrivé à quelqu’un?
Je suis en version 4.2.101 pour windows 7 64 bits

HELLLPPP


#2

Bonjour,

Vous pouvez donner une copie d’écran ?

Cdt

Antoine

Kelis

Antoine POURCHEZ


#3

Voila ! Merci
Frédéric


#4

Je précise que je suis informaticien, j’ai cherché si cela ne venait pas de l’antivirus en le désactivant : même soucis
Je suis administrateur du pc.


#5

Très étrange.

Vous avez essayé de désinstaller et réinstaller l’application ?

Vous pouvez donner le contenu de la fenêtre qui apparait après avoir exécuté la commande « Ctrl+Maj+J » ?

Antoine POURCHEZ


#6

Essayez de supprimer le profil applicatif local de SCchain (ex : C:\Users[userName]\AppData\Roaming\SCENARI\ch.4.2)

Antoine POURCHEZ


#7

Voila la console.
La désinstallation et réinstallation fait la même chose, pareil dans un autre répertoire.
J’ai effacé le contenu du répertoire ch.4.2, le profile se crée bien à la réouverture du logiciel. Mais le souci est le même.
Je travail en université, c’est pour une salle de pc pour un cours d’un enseignant.


#8

Le système n’arrive pas à trouver un port libre sur la machine. Je n’ai jamais vu ça encore. Peut-être une restriction de sécurité bas niveau, ou un firewall pas suffisamment permissif.

Pour passer outre cette recherche de prot libre, vous pouvez définir manuellement un port de travail (après avoir vérifié qu’il était bien libre) via cette procédure :

  •      Ouvrir le fichier [app]\bin\scApp\defaults\preferences\50.app.conf.js
    
  •      Y ajouter la ligne pref("scenaripref.servers.embeddedServer.port", "8090");
    

Ps : remplacer 8090 par le port que vous avez choisi.

Cordialement,

Antoine

Kelis

https://forums.scenari.org/t/probleme-dacces-au-menu-atelier-dans-scenari-chain-4-2/833/7 Visit Topic or reply to this email to respond.

To unsubscribe from these emails, https://forums.scenari.org/email/unsubscribe/294c744040b1f04c67ceee392dec994dda0d2f7d1a0da161bd745b0dc9bd1ae0 click here.


#9

J’ai le menu du haut qui s’affiche comme sur la copie d’ecran, et je reste en pendule comme cela, suite à vos manipulations,
J’ai essayé avec votre numéro de port, avec un autre, j’ai désactivé le pare-feu windows sur le poste,

Merci d’avance !


#10

Un process « java » est bien présent après avoir exécuté scChain ?

Vous pouvez vérifier la configuration du proxy (pas de proxy pour les url locales) ?

Antoine POURCHEZ


#11

Il n’y a pas de proxy pour les url locales.

Je bloque, au secours !


#12

Bonjour,

Récapitulons :

  • la couche java tourne
  • la couche cliente aussi
  • elles n’arrivent pas à communiquer entre elles, impossible de
    trouver un port libre
  • avec un port initialisé à la main, ça ne fonctionne pas non plus.

Votre machine bloque la communication à travers les ports… ce qui
empêche SCENARIchain ne fonctionner normalement.
À tout hasard, après avoir initialisé un port à la main, vous pouvez
consulter l’adresse : http://127.0.0.1:[port]/web/u/adminServer depuis
un navigateur web (en remplaçant le [port] par le numéro initialisé).

Théoriquement, vous devriez avoir une réponse en json avec quelques
informations techniques (numéro de version, numéro de build…).

Si vous n’avez rien, c’est qu’il est impossible de communiquer avec la
couche java à travers ce port… qui est donc bloqué par votre machine.
Et c’est donc qu’il y a une configuration, un pare-feu, un antivirus (ou
tout autre logiciel de sécurité visant à verrouiller les possibilités de
la machine) qui bloque les requêtes.

Je ne pense pas que ça ait grand chose à voir avec Scenari à ce stade.
Par exemple, si vous installez un serveur WAMP et que vous essayez de
consulter une page à une adresse locale, ça ne devrait pas fonctionner
non plus.

Il vous faut donc trouver et mieux paramétrer le logiciel qui bloque
l’ouverture des ports.

Thibaut


#13

je suis peut-être bigleux, mais moi je ne vois pas de javaw.exe dans la liste des processus…
Le problème serait alors plutôt que le lancement de l’exe java est bloqué par Windows.


#14

javaw.exe tourne pendant l’execution de scenari chain.

Voila ce que j’ai en retour de http://127.0.0.1:8090/web/u/adminServer
Ce qui m’a l’air correct.


#15

Et ça vous parle le message d’erreur suivant?

Merci, Frédéric


#16

J’ai trouvé, désolé pour le temps perdu,
C’est le logiciel de gestion des étudiants, Net op School qui bloquait le bon fonctionnement de scenari,

Merci, c’est vraiment agréable de se sentir soutenu en tous cas :slight_smile:
Frédéric


#17

Maintenant que vous avez fixez le port via pref("scenaripref.servers.embeddedServer.port", "8090");, qu’avez-vous dans la console (accès via Ctrl+Maj+J) lorsque vous relancez l’application ?


#18

Merci Spi mais c’est résolu; voir le post au dessus.

Merci beaucoup !