[RÉSOLU] Dépôts Ubuntu 18.04


#1

Bonjour,

est-ce qu’il y aurait une date pour l’ouverture d’un éventuel dépôt scenari pour ubuntu 18.04 LTS ?

bien cordialement


#2

Bonjour Patrice,

80% du temps, pour faire un dépôt suite à une nouvelle release ubuntu on
clone celui de la précédente version. Il faut juste savoir si cela
fonctionne bien avant.

Si tu es déjà passé en 18.04 tu peux essayer de te brancher sur le repo
Scenari en prétendant être la 17.10 (artful), avec les risques
classiques associé à jouer aux beta-testeurs.

Si cela fonctionne j’active le repo, sinon tout signalement de problème
peut être utile aux développeurs. De toute façon on est plusieurs
linuxiens intéressés, donc cela arrive tôt ou (pas trop) tard. Pour
toutes les versions précédentes ubuntu et debian, Samuel de Kelis a pris
le temps de jouer les cobayes rapidement après les sorties.

a+

Stéphane


#3

Bonjour,
avec artful on a :

Les paquets suivants contiennent des dépendances non satisfaites :
scenarichain4.2.fr-fr : Dépend: libscenarisrv4.2 (>= 4.2.106) mais ne sera pas installé

et quand on essai d’installer libscenarisrv4.2 on a

Les paquets suivants contiennent des dépendances non satisfaites :
libscenarisrv4.2 : Dépend: libav-tools mais il n’est pas installable

et quand on essai d’installer libav-tools on a

Aucune version du paquet libav-tools n’est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu’il est devenu obsolète
ou qu’il n’est disponible que sur une autre source
Cependant les paquets suivants le remplacent :
ffmpeg:i386 ffmpeg


#4

Pour t’en sortir, tu peux probablement :

apt-get install ffmpeg libav-tools-links

libav-tools-links est un package qui sert a juste à combler la dépendance libav-tools pour ceux qui ont déjà fait l’install ffmpeg.

Ensuite, on posera la question à @sam s’il est possible et judicieux de remplacer libav-tools par ffmpeg dans les dépendances des packets Scenari ?


#5

Pas de chance pour le paquet libav,
Le paquet libav-tools-links n’est pas dans les dépôts ubuntu bionic.
Note : ffmpeg était installé par défaut sur mon install fraîche de Bionic


#6

Bonjour,

En effet, Canonical a supprimé libav-tools entre le moment on j’ai testé Bionic (juste avant la version beta) et maintenant…

Laissez moi quelques jours pour creuser tout ça.


#7

Bonjour,

Les versions nightly DEB des applications SCENARI 4.2 sont maintenant dépendantes de ffmpeg et plus libav-tools. Elles donvent donc être installables sous Ubuntu 18.04. Les versions stables vont suivre d’ici quelques jours.

En atttendant l’ouverture du dépôt bionic, la ligne DEB pour les nightly est :
deb https://download.scenari.org/deb artful main nightly

Remarque : Le fait que Canonical supprime le paquetage de transition libav-tools implique que les DEBs des applications SCENARI ne seront plus compatibles avec Ubuntu 14.04 LTS. Ceci ne doit pas poser de problèmes car j’espère que plus personne utilise Ubuntu 14.04 !

Vu que 18.04 est également une LTS, supporter deux LTS c’est déjà bien !


#8

Merci @sam, ça fonctionne.
Si cela peut servir, j’ai les logs suivants qui s’affichent (au lancement de scenarichain4.2) :
Gtk-Message: 09:20:05.870: Failed to load module “canberra-gtk-module”
2018-05-02 09:20:07.903:INFO::main: Logging initialized @475ms
2018-05-02 09:20:08.272:INFO:esjs.Server:main: jetty-9.1.4
2018-05-02 09:20:08.750:INFO:esjsh.ContextHandler:main: Started e.s.j.s.ServletContextHandler@290d210d{/,null,AVAILABLE}
2018-05-02 09:20:08.802:INFO:esjs.ServerConnector:main: Started ServerConnector@7f1302d6{HTTP/1.1}{127.0.0.1:41755}
2018-05-02 09:20:08.804:INFO:esjs.Server:main: Started @1524ms
2018-05-02 09:20:14: basic_code_modules.cc:70: ERROR: Module /usr/lib/libscenarixul4.2/libmozsqlite3.so could not be stored
2018-05-02 09:20:14: basic_code_modules.cc:70: ERROR: Module /usr/lib/libscenarixul4.2/liblgpllibs.so could not be stored
2018-05-02 09:20:14: basic_code_modules.cc:70: ERROR: Module /usr/lib/libscenarixul4.2/components/libdbusservice.so could not be stored


#9

Oui… c’est ‘normal’.
Quand on démarre les application scenari deb en ligne de commande on a directement toutes les traces des différentes parties de l’application (front Xul et Java).
Les logs basic_code_modules.cc sont issues du moteur Xul, ils ont toujours existé et ne semblent avoir aucun impacte.


#10

OK, et le module canberra-gtk-module n’a pas d’impact sur le visuel de l’application ?


#11

Il suffit d’installer la dépendance :
sudo apt install libcanberra-gtk-module
pour faire disparaître le warning.
Autre avantage : scenarichain se lance alors immédiatement

NB je suis sous Bionic 64 bits


#12

canberra-gtk-module : translates GTK+ widgets signals to event sounds

Visiblement canberra-gtk-module n’est plus installé automatiquement dans Bionic, il est dans “Univers”.
Je sais pas exactement pourquoi, avant c’était une dépendance de
unity-control-center et gnome-control-center entre autre, donc toujours installé par défaut.

Je l’ai ajouté comme dépendance des debs incluant xul chez nous.


#13

Les disparitions et apparitions de dépendances : une histoire sans fin :hourglass_flowing_sand:


#15

Bonjour,
Le dépôt Ubuntu Bionic est maintenant ouvert et l’ensemble des applications basées sur SCENARI 4.2 sont maintenant installables et compatibles avec Ubuntu 18.04.