Publication diaporama opale 3.8

Bonjour,

Vous avez câblé le dossier de skin de la publication Web sur le générateur Diaporama.

Samuel.

j’ai pas compris ?

Dans votre zip, on retrouve bien une publication Diaporama, par contre le dossier skin ne contient pas un habillage de Diaporama mais un habillage de publication Aurora Web.

Les publications Web et diaporama sont totalement différents et leurs skins ne sont pas du tout compatibles.

Dans Styler vous avez associé auroraW.skin.doss à la publication Diaporama, ce qui n’est pas possible.

Hello,

Il semble que l’atelier Styler organisé à l’occasion des Rencontres Scenari 2021 apporterait des réponses à vos interrogations. (mais je vois que vous y êtes déjà inscrit, alors disons que c’est pour partager l’info avec d’autres visiteurs de ce flux :grinning:)

Prérequis ;

Au plaisir de nos échanges aux TRS2021.
JPC

@sam , vous avez raison !

Dans styler j’ai utilisé la même auroraW.skin.doss pour les trois types de publication WEB,SCURM, diaporama

Donc je vais créer un autre auroraW.skin.doss pour la publication diaporama.

Merci pour votre soutien et votre disponibilité.

Salutations

@JPC-AURA ravie d’assister à une rencontre très intéressante avec une équipe sympathique comme vous

Merci infiniment :blush:

Ce sera plus auroraD.skin.doss.

Par contre pourquoi vous utilisez toujours Opale 3.8. Il serait judicieux de passer à Opale 3.9, surtout pour le diaporama qui a été entierement revu pour fonctionner le local (sans serveur http).

bonjour @sam
super !
ca marche très bien avec auroraD.skin.doss. merci pour votre soutien :grinning:

oui je vaudrai utiliser Opale 3.9, mais je dois passer vers la nouvelle version du Scenari-chain-server 5.0.1.01 ou bien j’utilisais ma version actuelle 5.0.0.08 ?

Merci d’avance.

Nous vous conseillons vivement de mettre à jour votre serveur, en effet 5.0.1.01 contient des corrections importantes c.f. ce post.

En effet il sera nécessaire de passer à SCENARIserver 5.0.1.01 pour utiliser la dernière version de Opale 3.9.

@sam est ce que il y a un guide détaillé pour passer de la version 5.0.0.08 a 5.0.1.01

ou bien je vais entamer une nouvelle installation ?

Comment avez-vous installé le serveur au départ ? et sur quel système ?

installation manuelle sous Ubuntu 20.04.1 LTS, j’ai utilisé la documentation ci-après :
https://doc.scenari.software/SCENARIchain-server@5.0/linux/fr/#$0:system

puis j’ai compiler mon war personnalisé avec scenari-builder 5.0.0.08, après j’ai lui déployer dans le répertoire /var/lib/jetty9/webapps

Alors il vous suffit de :

  • reprendre votre configuration adaptée lors de la premières installation et de l’appliquer à la configuration de la nouvelle version,
  • compiler le war
  • arrêter Jetty
  • faire une sauvegarde des données
  • remplacer le war dans le dossier /var/lib/jetty9/webapps
  • relancer Jetty

Par curiosité pourquoi avez-vous choisi cette façon d’installer SCENARIserver plutôt que le packaging DEB ou Docker ?

Bonjour @sam
j’ai réussit à mettre à jour le serveur vers la version 5.0.1.01, mais un erreur apparait lors de l’authentification comme la capture ci-après :

Par curiosité pourquoi avez-vous choisi cette façon d’installer SCENARIserver plutôt que le packaging DEB ou Docker ? j’ai l’envie de l’installer manuellement pour approfondir en cas de problèmes

Sans logs, on peut pas vous en dire plus… Mais c’est peut-être juste un pb de cache. Videz le cache de votre navigateur.

Bonjour @sam
j’ai vider le cache mais toujours même problème

je parlais des logs serveur

pas de logs sur serveur :

@sam des nouvelles pour ce problème ?

il y a vraiment rien d’autre dans le fichier de log ? là vous me montrez juste un tail -f