Problème génération export Moodle dans Opale 3.7

Bonjour,

J’ai installé l’export Exercices Moodle (version 17.1.0.00) sur mon Opale 3.7.001 et dès que je génère, j’ai systématiquement une erreur (même avec 1 seul item, en ayant rempli ou non les options d’export). Voici mon rapport, pouvez-vous me dire d’où vient le problème ? Pour info, j’ai testé la version antérieure de l’export sur mon Opale 3.6 et je n’ai aucun problème.

Traces de ‹ Export Moodle › pour l’item ‹ /Sauvegarde/BOEM/ProgAlgo_2020-12-14/ProgAlgo/mdl_programmation1.xml ›

— User details —
Générateur: gen_mdl - Export Moodle
Item racine: /Sauvegarde/BOEM/ProgAlgo_2020-12-14/ProgAlgo/mdl_programmation1.xml

  • Generation failed.

— Admin details —

<?xml version="1.0" encoding="UTF-8"?>
java.lang.NullPointerException at com.scenari.m.ge.generator.web.WebGenerator.xCopySkin2Dest(WebGenerator.java:363) at com.scenari.m.ge.generator.web.WebGenerator.xGenerate(WebGenerator.java:315) at com.scenari.m.ge.generator.base.GeneratorStatic.generate(GeneratorStatic.java:647) at eu.scenari.wsp.module.gen.ThreadGen.call(ThreadGen.java:170) at eu.scenari.wsp.module.gen.ThreadGen.run(ThreadGen.java:157) at eu.scenari.core.universe.Universe$1.run(Universe.java:393) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at java.lang.Thread.run(Unknown Source)

— Js stack —
cbLoadLog@chrome://scenariwsp/content/widgets/genBox/genBox.xbl.xml:805:11
CallbackWrapper.prototype.handleEvent@chrome://scenariwsp/content/commons/servers/HttpDataProvider.jsm:410:17

— App context —
timestamp: 14/12/2020 10:47:49
userAgent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 ch.4.2/4.2.104
coreVersion: 4.2.104
brandShortName: SCENARIchain
appVersion: 4.2.104
appBuildId: 201706281113
appDevelopmentStage: final

Merci pour votre aide,
Gaëlle

Quel est le skin utilisé ? En changeant de skin , l’erreur persiste ?

Sur l’export Moodle il n’y a pas de skin, donc le problème ne se situe pas là :wink:

Pas de solution de contournement en mettant à jour : Opale 3.7 3.7.0.01 final a maintenant 2 ans,
et l’extension Moodle n’est pas compatible pour l’instant avec Opale 3.8… Pas facile comme situation…

Essayer sur un autre poste ??

C’est une erreur systématique quelque soit le type de question,
ou bien ça ne concerne que certains types de question ?

Salut Gaëlle,

Pas vu de pb dans les contextes :

  • app Opale3.7.001_fr-FR_2018112117 standalone
  • ou pack opale3-7_fr-FR_001_201811211709_sc42.wsppack installé dans SCENARIchain-desktop 4.2.2.01.

Par ailleurs, la trace que tu as donné n’est cohérente que si le SCENARIchain (ou l’application Opale standalone) que tu utilises est antérieure au 05/10/2017, date à laquelle ce pb a déjà été corrigé :slight_smile:

Donc, je pense que tu exploites le pack Opale dans un SCENARIchain-desktop incompatible (4.2.1.04 ou antérieur).

Conclusion : update ton SCENARIchain-desktop (https://download.scenari.software/SCENARIchain-desktop@4.2.2.01/), et ça devrait être bcp mieux.

Antoine
Kelis

Bonjour Antoine,
En effet, la mise à jour a réglé le problème :partying_face: Je me rends compte que ma version était bien ancienne ^^’
Merci de ton aide,

Bonne journée,
Gaëlle

Est-ce qu’il y a un mécanisme de contrôle de vérification de la version minimum compatible du modèle, lors de l’installation d’une extension ?

@PascalBoulerie

Oui. Mais pour ce cas particulier, c’était un bug cœur, et pas une contrainte de compatibilité connue lors de la sortie de l’extension

1 « J'aime »