[Prématuré] dépot Debian Buster

Bonjour,
à l’installation du dépot scenari pour Debian Buster j’ai une erreur, je suis preneur de toute idée pour me permettre de l’effacer :
Ign :5 https://download.scenari.org/deb buster InRelease
Err :6 https://download.scenari.org/deb buster Release
404 Not Found [IP : 94.23.220.87 443]
Réception de :7 http://repository.crdp.ac-versailles.fr/debian xia/main amd64 Packages [597 B]
Lecture des listes de paquets… Fait
E: Le dépôt https://download.scenari.org/deb buster Release n’a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s’effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d’apt-secure(8) pour la création des dépôts et les détails de configuration d’un utilisateur.

cordialement
Patrice

Sans être spécialiste de Debian, je pense que :

  • Buster est la toute dernière version à être sortie
    tout récemment le 6 juillet 2019 (il y a quelques jours seulement)
    d’après ce que je lis là : https://fr.wikipedia.org/wiki/Debian

Stretch est la version précédente :

Stretch est connue et reconnue par Scenari, il y a un dossier dans la liste :
https://download.scenari.org/deb/dists/

https://download.scenari.org/deb/dists/stretch/
avec un fichier Release

Je pense qu’il faut que l’équipe des développeurs adapte le paquet pour la dernière version Debian Buster

(Pourquoi travaillez-vous sur une version toute récente ? Pour faire des essais, ou déjà sur un serveur de production ???

Pour faire un essai, avez-vous un moyen d’outrepasser la sécurité * et de charger la version Scenari pour Debian Strech et voir comment elle se comporte sur Debian Buster ?)

  • mettre à jour de manière non sécurisée…

Bonjour,
en fait j’ai deux collègues (et ma sœur) qui viennent de passer sous Debian Buster (10) et qui ont ce problème. Je l’ai reproduit en installant Buster sur un ordi (en production j’utilise Stretch).
Je pense que le dépot sera mis à jour par les développeur en même temps que l’upgrade vers Scenari 5. Mes collègues vont attendre ou bien essayer de voir si ça tourne avec le dépot Stretch effectivement.
cordialement,
Patrice

J’espère qu’ils sont calés en informatique, parce que dans certains cas, il vaut mieux laisser les utilisateurs aguerris essuyer les plâtres lors d’une mise à jour…
(ce sont les mises à jour de sécurité qui sont importantes à suivre, pour le reste 2 ou 3 semaines de retard ça n’est pas gravissime pour un utilisateur)

Bonjour,
les spécialistes en informatique utilisent la Debian Buster depuis deux ans. Maintenant qu’elle est sortie en version stable 10 c’est certainement la distribution linux la plus stable qui existe. Les collègues en questions avaient décidé de mettre à jour une très vieille version de debian (ou d’ubuntu c’est selon) en début de vacances scolaires : il s’avère que la Debian Buster 10 est sortie le 6 juillet alors je pense qu’ils ont bien eu raison de profiter de cette debian stable toute fraiche :slight_smile: Je pense sincèrement qu’ils auront moins de soucis éventuels avec cette nouvelle Debian qu’avec une Ubuntu LTS 18.04.

1 J'aime

Merci de ce retour, nous allons ajouter Debian Buster à notre liste de dépôts. en attendant vous pouvez utiliser celui de Stretch.

Cela devrait être bon, vous pouvez maintenant tester le repo buster. Comme pour les mises à jour de distribution qui ne semblent pas impacter Scenari, ce sont les mêmes packages que stretch. Prévenez nous en cas de problème.

Si, il y a un impact mais il vaut mieux que l’OP le découvre par lui-meme et qu’il en informe le support directement, les app. scenari 4.x ne sont pas 100% compatibles avec Buster!