Pb Edition documents

Bonjour,
Depuis une semaine, lorsque je veux voir l’aperçu d’un document odt j’ai le message ci-dessous qui apparaît
De plus, lors de l’édition et de la tentative d’enregistrement des modifications, j’ai l’indication que le fichier ne peut pas s’enregistrer à l’emplacement " http://127.0.0.1:49300/api/u/wspDav/GPME" GPME est le nom de mon atelier.

Je travaille sous windows 8 avec la version scenari 4.2 Opale 3.7 et LibreOffice 6.1

Message d’erreur à l’affichage d’un fichier odt :

<message type="Error" ts="1559453153906" appCtx="chain" thread="qtp16093701-13" desc="Send dialog result failed for : %s" var1="Dialogue du service=[Svc:wspSrc]; Class=eu.scenari.wsp.service.wspsrc.SvcWspSrcDialog"><message type="Error" ts="1559453153906" appCtx="chain" thread="qtp16093701-13" desc="Send result failed : eu.scenari.wsp.service.wspsrc.SvcWspSrcSender"><message type="Error" ts="1559453153906" appCtx="chain" thread="qtp16093701-13" desc="OpenDocument editor not found."><message type="Exception" ts="1559453153906" appCtx="chain" thread="qtp16093701-13"><details>java.lang.NullPointerException

at java.io.File.<init>(Unknown Source)

at eu.scenari.transform.od.TfmOpenDocument.getOoClassLoader(TfmOpenDocument.java:346)

at eu.scenari.transform.od.TfmOpenDocument.xGetSubTransformer(TfmOpenDocument.java:188)

at eu.scenari.transform.od.TfmOpenDocument.getFileExtension(TfmOpenDocument.java:182)

at com.scenari.m.bdp.item.fs.XItemCacheData.transformAsStream(XItemCacheData.java:426)

at com.scenari.m.bdp.item.fs.XItemCacheData.transformAsNode(XItemCacheData.java:522)

at com.scenari.m.bdp.item.fs.WspSrcNodeItem.transformAsNode(WspSrcNodeItem.java:915)

at com.scenari.src.feature.transform.SrcFeatureTransform.transformAsNode(SrcFeatureTransform.java:133)

at eu.scenari.wsp.service.wspsrc.SvcWspSrcSender.xSendDialogResult(SvcWspSrcSender.java:419)

at eu.scenari.core.execframe.httpservlet.SenderHttpResponseBase.sendDialogResult(SenderHttpResponseBase.java:74)

at eu.scenari.core.execframe.httpservlet.reqconn.HttpRequestConnectorApi.sendResponse(HttpRequestConnectorApi.java:130)

at eu.scenari.wsp.execframe.HttpRequestConnectorUiMoz.sendResponse(HttpRequestConnectorUiMoz.java:181)

at eu.scenari.core.execframe.httpservlet.HttpRequestConnectorBase.handleRequest(HttpRequestConnectorBase.java:77)

at eu.scenari.core.execframe.httpservlet.servlets.ServiceServlet.service(ServiceServlet.java:160)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)

at eu.scenari.jetty.servlet.ServletHolder.handle(ServletHolder.java:738)

at eu.scenari.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:551)

at eu.scenari.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1111)

at eu.scenari.jetty.servlet.ServletHandler.doScope(ServletHandler.java:478)

at eu.scenari.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1045)

at eu.scenari.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)

at eu.scenari.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)

at eu.scenari.jetty.server.Server.handle(Server.java:462)

at eu.scenari.jetty.server.HttpChannel.handle(HttpChannel.java:279)

at eu.scenari.jetty.server.HttpConnection.onFillable(HttpConnection.java:232)

at eu.scenari.jetty.io.AbstractConnection$1.run(AbstractConnection.java:534)

at eu.scenari.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:607)

at eu.scenari.jetty.util.thread.QueuedThreadPool$1.run(QueuedThreadPool.java:536)

at java.lang.Thread.run(Unknown Source)

Cordialement
Jean-Luc Sacher

Le message “OpenDocument editor not found.” indique que Scenari ne trouve pas l’éditeur OpenDocument.

LibreOffice 6.1
Dans d’autres discussions, il me semble qu’il faut avoir installé sur la machine Scenari un LibreOffice compatible version 5 .

Bonjour,
J’ai essayé de passer à LO5, ça n’a rien changé. Je vais réessayer.
Je peux éditer le document, mais impossible de l’enregistrer une fois la modification faite, message "[http://127.0.0.1:49300/api/u/wspDav/] introuvable
Cordialement
Jean-Luc Sacher

Bonjour,
J’ai réglé le problème en installant une version 32 bits de libre office, même si mon ordinateur supporte une version 64 bits.
Si ça peut être utile à d’autres utilisateurs.
Cordialement
Jean-Luc Sacher