Migration wsppack


#1

Bonjour,
jusqu’à très récemment j’utilisais Opale 3.5 pour éditer mes documents. Ayant migré vers Opale 3.6 je me retrouve avec un modèle documentaire wsppack non utilisable car conçu sous un environnement scenari trop ancien (4.1).

Y a t’il une solution pour reprendre ce wsppack et le mettre au gout du jour sous mon nouvel environnement ?
Merci


#2

Bonjour,

Je ne comprends pas tout à fait votre problème :

Cordialement,

Antoine

Kelis


#3

Bonjour,

Pour utiliser Opale 3.6, il faut installer SCENARIchain 4.2. Nous gérons
la compatibilité ascendante, pas la rétro-compatibilité.


#4

Bonjour,

Si vous avez désinstallé scenari 4.1+Opale3.5 et installé scenari 4.2 et Opale 3.6. Vos ateilers sont effectivement vu comme ne erreur à l’ouverture dans opale 3.6. Si vous travaillez en local (pas sur un serveur scenari) ma procédure est la suivante :

  • vous avez l’atelier original en 3.5 dans un dossier correspondant à Scenarichain 4.1 par exemple c:\users\moncompte\documents\scenarichain4.1\monatelier
  • copiez cet atelier dans le dossier équivalent pour scenari 4.2
  • Ouvrez Scenari4.2 et cliquez sur le bouton “Ajouter”
  • Dans le “code de l’atelier” entrez le nom de votre atelier identique au nom du dossier qui vient de Scenari 4.1
  • Scenari doit vous indiquer le message suivant : “Une définition d’atelier existe à cet emplacement” avec un bouton “Reprendre cette définition d’atelier”
  • Cliquez sur ce bouton. Cela créé l’atelier dans Scenari42 mais celui-ci est en erreur car il correspond à un atelier opale3.5
  • cliquez sur le bouton “propriétés” de ce nouvel atelier. Le champ “Etat de l’atelier” vous indique “Atelier en échec”
  • Allez dans l’onglet “Edition des propriétés” Il doit être sélectionné “Opale 3.5 modèle d’atelier inconnu”
  • sélectionnez sur Opale 3.6 puis valider
  • un dialogue demande validation pour la migration Opale 3.5 vers Opale 3.6
    Une fois terminé vous avez votre contenu dans Opale 3.6

Cordialement


#5

C’est effectivement ce type de problème, un service a conçu le wsppack spécifique mais ce dernier n’est pas exploitable depuis la migration vers Opale 3.6. Je vais essayer de récupérer l’atelier et de le déplacer.
Merci pour vos réponses


#6

Si vous avez le wsppack mais pas l’atelier il y a une autre solution plus simple.

  • Dans Scenari4.2 au lieu de cliquer sur ajouter vous déroulez le menu sur ce bouton Ajouter. Il y a une commande “Créer un atelier depuis une archive”
  • entrez le nom que vous voulez pour cet atelier puis donnez lui le wsppsack
  • une fois validé ça créera un atelier dans Scenar4.2 avec le contenu d’opale 3.5
  • L’atelier sera encore en opale 3.5. Vous devez aller sur propriété sur cet atelier et lui dire que c’est désormais de l’opale 3.6
  • la migration s’effectue et vous pouvez utiliser votre atelier

Cordialement
Franck


#7

Effectivement la solution est simple et fonctionne, merci pour la rapidité de votre réponse.