Migration opale 3.6 vers la plus récente

Bonjour

J’ai voulu récupérer mon contenu associé à Opale 3.6 associé à ScenariChain 4.2 aujourd’hui. Après avoir installé Scenarichain 5.0 et les mauvaises versions d’Opale, j’ai réinstallé ScenariChain 4.2 et Opale 3.6. Je suis rassurée de tout récupérer ainsi à court terme. Mais je me dis qu’il faudrait quand même que je mette à jour tout cela avec les nouvelles versions. Comment dois-je procéder ? La migration semble bloquer en marquant que cela a été réalisé avec des versions anciennes.
Merci d’avance pour votre aide.

Bonjour,

tout d’abord, faites une sauvegarde de votre atelier Opale 3.6 (clic droit « exporter l’atelier »), afin d’avoir les contenus en sécurité en cas de mauvaise manip.
Ensuite, installez ScenariChain 5.0 et installez-y Opale 3.8.
Ouvrez scChain et créez un nouvel atelier Opale à partir d’une archive.
Une fois l’atelier créé, dans les propriétés passez-le à Opale 3.8. C’est à ce moment que la migration sera proposée.

Bonjour @lalejand
Merci beaucoup. J’avais fait par dossier et sans doute pas coché les bonnes cases après l’importation pour pouvoir adapter à 3.8. En tout cas, cela a très bien marché avec l’archive. Merci beaucoup.

Pour info, la procédure est décrite en détail ici.

Bonjour (et bonne année :slight_smile:
j’ai le même soucis: contenu Scenari 4 - Opale 3.7 qui ne veut pas s’importer dans Scenari 5 - Opale 3.8.

J’ai tenté cette méthode mais quand le nouvel atelier se charge d’après l’archive, il m’indique « atelier en échec ». Il m’indique que le modèle Opale 3.7.001 (avec les extensions Emeraude et Quadra) est inconnu.
Je n’ai pas trouvé de wspack pour installer Opale 3.8 sur Scenari 5 ni Opale 3.7 sur Scenari4.
Auriez-vous un conseil svp ?
Merci d’avance.

Bonjour,
Que Scenari 5 indique « Atelier en erreur » c’est normal puisqu’il ne connait pas le modèle Opale3.7 qui ne tourne que sur Scenari 4.2.
Pour effectuer la migration vers Scenari 5, il vous faut donc installer le wsppack d’Opale 3.8 qui se trouve sur l’espace de téléchargement de Scenari https://download.scenari.software/fr/
Une fois installé vous ouvrez votre atelier avec Scenari 5. Il vous indique que l’atelier est en erreur. Il vous suffit alors d’aller dans les propriétés de l’atelier et d’indiquer qu’il s’agit d’un opale 3.8. La migration se déroule et l’atelier est opérationnel sous Scenari 5.

Cordialement
Franck

1 J'aime

Le site de téléchargement est indiqué dans le message épinglé de la catégorie Opale : Opale : à propos / documentation / téléchargement / ressources

@arnaud_leleve tu as pu faire ta migration des contenus ?

Bonsoir,

désolé, je n’ai pas eu le temps de me repencher sur ce sujet depuis.

J’ai installé Opale 3.8 dans Scenari 5; la pack apparaît bien dans la fenêtre de gestion des packs.
Quand j’ouvre les propriétés du cours importé, l’état de l’atelier est « Atelier en échec », et le modèle associé Opale 3.7.

Quand je passe dans l’onglet « Edition des propriétés », seul Opale 7 est proposé (et coché).
Par curiosité, j’ai tenté de le décocher mais quand je lui demander d’enregistrer, scenari semble planté sur « Enregistrement en cours… » indéfiniment.

Si tu as installé Opale 3.8 dans sc5, tu devrais avoir la possibilité de choisir le modèle Opale 3.8 dans les propriétés. Tu peux mettre une copie écran des propriétés ?
Je fais référence à cet écran là :

J’ai SCENARI Chain Desktop 5.0.0.08 final pour Ubuntu.
Quand j’affiche les propriétés du cours importé, j’obtiens la fenêtre suivante:

J’ai bien Opale 3.8 dans mes packs:

Hello,
Sauf erreur, selon ton image sont installés des compléments à Opale, mas pas Opale lui-même.
Il est en téléchargement ici : https://download.scenari.software/Opale@3.8.0.12/

Oui, effectivement, bien vu! Merci beaucoup :slight_smile:

Je l’ai installé via le dépôt Ubuntu mais il a du s’installer pour la version 4, pas la 5; je n’ai pas fait gaffe à ce détail…

Ca marche désormais.

Merci à tous pour votre aide.