Les documents LibreOffice ne passent plus

Bonjour,
Aujourd’hui en essayant de publier, j’ai reçu des messages d’erreurs qui indiquent l’impossibilité d’accepter les documents offices qui passaient sans problème avant.

Voici le rapport:

Traces de ‹ Support web Aurora › pour l’item ‹ /Cours02/Publications/Cours02Web.publi ›

— User details —
Générateur: gen_auroraW - Support web Aurora
Item racine: /Cours02/Publications/Cours02Web.publi

  • Starting OpenDocument editor in pipe mode.
  • Echec à la transformation de la ressource ‹ src:/Cours02/Equations/21 Exemple_debit.odf/21 Exemple_debit.odf?transform=odf2mml › dans .
    • Echec à la transformation ‹ transform=odf2mml › sur l’item
      • Echec à la transformation d’une ressource (OpenDocument).
        • Connection to server failed : uno:pipe,name=sc7402528158907245697;urp;StarOffice.ComponentContext
  • Starting OpenDocument editor in pipe mode.
  • Echec à la transformation de la ressource ‹ src:/Cours02/Equations/22 Exemple_vitessemoyenne.odf/22 Exemple_vitessemoyenne.odf?transform=odf2mml › dans .
    • Echec à la transformation ‹ transform=odf2mml › sur l’item
      • Echec à la transformation d’une ressource (OpenDocument).
        • Connection to server failed : uno:pipe,name=sc1957143254356547918;urp;StarOffice.ComponentContext
  • Starting OpenDocument editor in pipe mode.
  • Echec à la transformation de la ressource ‹ src:/Cours02/Equations/23 Exemple_pertes_premier.odf/23 Exemple_pertes_premier.odf?transform=odf2mml › dans .
    • Echec à la transformation ‹ transform=odf2mml › sur l’item
      • Echec à la transformation d’une ressource (OpenDocument).
        • Connection to server failed : uno:pipe,name=sc2706415993011637595;urp;StarOffice.ComponentContext
  • Starting OpenDocument editor in pipe mode.
  • Echec à la transformation de la ressource ‹ src:/Cours02/Equations/24 Exemple_pertes_second.odf/24 Exemple_pertes_second.odf?transform=odf2mml › dans .
    • Echec à la transformation ‹ transform=odf2mml › sur l’item

Bonjour Michel,
Vous rencontrez le problème sur un environnement SCENARIchain ?
Si oui, il faut vérifier l’installation de LibreOffice 6 sur votre machine, avec qui scenari ne sembple pas pouvoir communiquer.
Cdt,
Antoine
Kelis

Bonjour, est-ce que cela veut dire que LO 7 ne fonctionne plus ? Merci Frédérique

Hum,
Opale 3.x, et plus globalement les chaines éditoriales construite avec SCENARI5.0, sont compatibles LibreOffice 6.
La compatibilité avec LibreOffice 7 viendra avec Opale4 (et SCENARI6.0).
Cdt
Antoine
Kelis

Merci Antoine,
La semaine dernière mes formules latex élaborées sous LO7 étaient admises. Mais donc pas suffisamment fiable…

Merci pour vos commentaires.
Pour l’installation j’ai 2 ordis
desktop Win11 + LibreOffice 6.0.7.3 64bits
laptop Win10 + LibreOffice 7.1.1.2 64bits
J’utilise MyScenari à jour version locale et en ligne. Les deux donnent le même résultat.
J’ai fait des corrections j’ai remplacé les formules Math par du Latex et j’ai remplacé le fichier .ods par une image .png. Ça a résolu le problème pour la publication web mais pour la publication pdf postscriptum j’ai le message d’erreur suivant:

Même résultat pour les 2 ordis.
Donc inconsistence entre publications en version web et version Postscriptum

J’ai remarqué aussi que dans le document web, il subsistait des formules mathématiques en libreOffice qui sont acceptées. Et tout ça n’est pas du nouveau matériel, il fonctionnait avant.
???

Bonjour,
Il faut distinguer :

  • le service myScenari distant, hébergé sur un serveur : dans ce cas, les interactions entre scenari et LibreOffice se passent exclusivement coté serveur, et ne dépendent en aucun cas de la configuration locale de la machine. LibreOffice 6 est installé sur ce serveur.
    Il est recommandé d’utiliser dans ces contenus des ressources OpenDocument (odt, ods, odg) éditées avec LibreOffice 6-, mais il est fort possible que la plupart des ressources LibreOffice éditées avec LibreOffice 7 fonctionnent (tout dépend des capacités de LibreOffice6 à lire des ressources LibreOffice7…).
    13/01/2022 : une action de maintenance est programmée (en cours je crois) sur ce service pour résoudre justement un problème de lien du serveur avec LibreOffice, rendant inopérantes les actions en lien avec les ressources OpenDocument (visualisation es ODG/ODS, …)

  • l’application locale myScenari : dans ce cas, les interactions entre scenari et LibreOffice se passent exclusivement sur la machine hôte. C’est LibreOffice6 qui doit être utilisé avec Opale 3 (le lien scenari > libreOffice est configurable dans l’écran des préférences de l’application, si vous avez plusieurs versions de libreOffice installées sur votre poste et que vous voulez en choisir une particulière). LibreOffice7 n’est clairement pas compatible avec Opale3 (plus globalement, pas compatible avec les chaines éditoriales produites avec SCENARI 5).

Remarque : Opale4 (et scenari6) seront compatibles LibreOffice7.

Cdt
Antoine
Kelis

1 « J'aime »

Bonjour Michel,

Je pense que le cache des ressources (ie la réutilisation des transformations des ressources (en image) déjà effectuées si la ressource OD associée n’a pas changé) brouille l’analyse.

Vous cumulez par ailleurs deux problèmes : un sur le service distant myScenari (en cours de résolution), et un sur votre machine pour les échecs sur un myScenari local (lien scenari > LibreOffice inopérant).

Quelle est la trace d’erreur obtenue sur le myScenari local ?
Cdt
Antoine Kelis

Merci beaucoup Antoine pour la pédagogie et le temps passé à répondre, c’est maintenant beaucoup plus clair.
Cordialement
Frédérique

Bonjour,

Comme précisé par @anp, une opération de maintenance du serveur myScenari vient d’avoir eu lieu pour améliorer la performance du lien à LibreOffice.

L’opération est terminée,
Thibaut

Votre support est vraiment fantastique. Je donne un cours ce soir et c’est réglé. Fiouf!
Pour la version en ligne, il reste un petit problème d’un autre ordre je crois dans Postscriptum . C’est avec l’index des mots clés, une fois enlevée, problème réglé.
Voici les pages pdf des mots clés qui causent l’erreur:

Voici le rapport d’erreur:

Une erreur est survenue lors de la génération.

— Admin details —

<?xml version="1.0" encoding="UTF-8"?>

— Context —
reg: {« envKeys »:[« itemType »,« securityCtx »],« parent »:{« envKeys »:[« wsp »,« securityCtx »,« uiRoot »,« place »,« infoBroker »,« wedSearchCoord »],« parent »:{« envKeys »:[« resolver »,« universe »,« securityCtx »],« parent »:{« envKeys »:[« resolver »,« noAuthentication »,« universe »,« securityCtx »]}}}}
uiContext: undefined
wsp: undefined
shortDesc: {« lcSt »:"",« srcId »:« id:06IyQGysRJtglXaUwPt2KR »,« srcStamp »:« 1J9Jk+cD2xgLs1/jf0nqq9oUeeffoCJR1vuftPUVAdQ= »,« srcUri »:"/Cours02/Publications/Cours02Papier.publi",« srcDt »:1642086893283,« srcSt »:1,« itSgn »:"@op_odRoot#Xml#Map",« itSt »:1,« itModel »:« op_odRoot »,« srcRi »:511,« srcRoles »:[« main:manager »],« srcUser »:« MichelSabourin »}
pubNode: {« ch »:[{}]}
genInfo: {« codeGenStack »:« auroraP »,« title »:« Support papier PDF Aurora (Postscriptum) »,« status »:« warning »,« lastGen »:1642086918696,« uriPub »:"/001yQGysRJtglXaUwPt2KR/C11443/PO8SBD/ISDMFK/QH7Q22/BK/~MichelSabourin/auroraP/Cours02Papier.pdf",« uriTraces »:"/001yQGysRJtglXaUwPt2KR/C11443/PO8SBD/ISDMFK/QH7Q22/BK/~MichelSabourin/auroraP/meta/~Traces.xml",« mimeDownload »:« application/pdf »,« skin »:« default »,« user »:« MichelSabourin »,« storedProps »:{« resolution@stored »:« high »,« publishDecoImg@stored »:« yes »},« skins »:[{« code »:« default »,« title »:« Habillage standard »}]}
genProps: undefined
cidInfo: null

— App context —
url: MyScenari - michelsabourin,
timestamp: 13/01/2022, 10:15:36
userAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/97.0.4692.71 Safari/537.36

Même message d’erreur sur la version locale.

J’ai maintenant installé LibreOffice 6 sur mon portable. Même résultats.

Encore merci pour votre support.
Michel

La génération Postscriptum n’a rien à voir avec LibreOffice. C’est un moteur de rendu PDF.
Tu enlèves quoi pour « régler » ton problème ?
C’est bizarre ce qui se passe sur ton index des mots clés. En plus la dernière ligne se superpose avec le numéro de page.
@david_rivron tu as une idée de ce qui peut se passer ?

Je mets non à Publier l’index des mots clés.
Ça ne règle pas vraiment le problème …

Peux-tu envoyer un mini-scar pour qu’on puisse constater le problème ?

C’est pas si petit, 11,3 Mo et il refuse de le prendre sous prétexte que ça dépasse 16 Mo.
Où pourrais-je le déposer?

Je l’ai mis ici:

https://michelsabourin.scenari-community.org/Énergieetturbineshydrauliques_2022-01-13_11-14-39.scar

C’est quelle version d’Opale ?

J’ai plein d’items en erreur car il manque dans le scar tous les items qui sont dans « outils généraux » chez toi.
Refais-nous un scar avec cette méthode : clic droit sur l’item de publication papier > exporter une archive. « inclure le réseau descendant complet de cet item » doit être coché.

Fait.

https://michelsabourin.scenari-community.org/Énergieetturbineshydrauliques_2022-01-13_12-01-04.scar
Pour la version Opale, c’est 3.9.

J’ai isolé le problème : c’est le renvoi vers un grain de contenu qui se trouve dans l’explication de l’exercice numérique 3 qui est utilisé dans la liste d’exercices quizCours02.xml.
image

Solution à court terme : ne pas faire ce renvoi.

Solution à moyen terme : @david_rivron je crois qu’il y a un bogue là.