Impossible de générer un package SCORM

Bonjour à tous,
Je vous présente mon souci sur la génération de package SCORM. J’ai créé un atelier dans scenarichain 4.2. Maintenant la génération SCORM est sans échec alors que la génération web est réussi.
Quelu’un a une idée pour résoudre le problème ???

Bonjour,

Vous utilisez quelle modèle documentaire ?
Donnez nous plus d’information, traces ? copies d’écrans ?

J’utilise le modèle Opale 3.7. L’erreur affiche le message suivant :

Message d’erreur :

Générateur: gen_packScorm2k4 - packaging SCORM 2004
Item racine: /&/&_web.publi

  • Generation failed.
    • taskdef class com.scenari.m.co.ant.LogMsgTask cannot be found using the classloader AntClassLoader[]
      • com.scenari.m.co.ant.LogMsgTask
        ===========================================

& ?
Pourquoi nommer l’espace de travail ainsi ??

Mieux vaut lui donner un nom en caractères non accentués.
(au cas où ce soit ça la source de l’erreur…)

D’accord, je vais tester en créant un autre nom.

Après création d’un nouveau atelier, nouveau module, nouveau contenu de module (QCU), je retombe sur le même problème.


Pourtant la publication Web est bel et bien réussie.
J’ai aussi déjà réinstallé Opale mais rien !
Qu’est-ce que vous me conseillez ???

Bonjour,

vous avez toujours la même erreur :

?

En effet !

  • taskdef class com.scenari.m.co.ant.LogMsgTask cannot be found using the classloader AntClassLoader[]
    • com.scenari.m.co.ant.LogMsgTask

Il semblerait que votre version de Scenari soit une ancienne 4.2 antérieure au 27/09/2016 (et on a un loupé sur un contrôle de compatibilité interne entre le pack que vous avez installé et la version du SECNARIchain).

Pouvez-vous installer la dernière version 4.2 de Scenari : https://download.scenari.software/SCENARIchain-desktop@4.2/

(ou la version serveur si vous êtes en serveur).

1 J'aime

D’accord, je refais le test avec la version 4.2.2.01 de ScenariChain.
Je suis en mode Desktop mais j’ai aussi WampServer déjà installé dans mon PC au cas où ça pourrai servir (version serveur ??)

Oui, si vous avez un SCENARIchain-server installé quelque-part et que vous l’utilisez, il faut aussi le mettre à jour.

1 J'aime

Je viens de désinstaller mon ancienne version de ScenariChain et installer la version la plus récente. De plus, j’ai mis Opale 3.6 au lieu de Opale 3.7. Et maintenant le problème est résolu. Je peux générer le Package SCORM sans problème.
C’est donc un problème de version (bug ?) ?
En tout cas, merci beaucoup à vous tous. Vous êtes formidable.

J’espère que vous voulez dire le contraire !