Formule LaTeX - Gen PDF - symbole € - Scenari4.2/Opale3.6


#1

Bonjour,

J’ai un problème avec la génération PDF, je n’arrive pas à faire en sorte que le symbol € s’affiche.

Latex error : ! Undefined control sequence. \u-default-8364 ...ifx \euro \undefined \texteuro

Faut-il installer un package complémentaire pour LaTeX sur le serveur (Debian) ?

Merci pour votre aide.


#2

Latex error

L’erreur concernant Latex ,
qu’ indique le manuel de ce logiciel-là, Latex ?


#3

Salut Mory,

Si tu n’as pas réglé ton problème, tu peux essayer une génération LaTeX
hors Scenari pour déjà bien identifier la chose (avec sharelatex par
exemple).

À suivre,

Steph.


#4

Bonjour Mory,

A mon avis c’est une combinaison de 2 choses, lors du développement des premières fonctionnalités d’utilisation du moteur LaTeX (cela doit faire environ 7 ans) :

  • On a testé principalement sur les usages en sciences fondamentales. Donc s’il faut une librairie pour traiter \euro, on l’a pas mis…
  • Il est possible que l’on utilise pas la meilleure méthode pour traiter de l’UTF-8. A l’époque, on utilisait la librairie utf8x, qui a pour effet dans certains cas de convertir les caractères spéciaux en commandes LaTeX, donc le carractère € ne passe peut être pas par défaut. Pour les nouveaux projets en général on utilise XeLaTeX qui supporte nativement l’UTF-8 avec les fonts de l’OS.

Tu peux tenter d’installer et de l’ajouter \usepackage[option]{eurosym} dans le préambule Scenari avec cette méthode : https://trac.scenari.org/modelet/wiki/math/latex#Surchargerlepréambule

Je ne sais pas si ce serait suffisant.

Stéphane


#5

Bonjour Stéphane P,

Merci pour ces informations. Je vais regarder ça. Je vous tiendrai au courant, ça pourra sans doute servir à d’autres.


#6

Bonjour,

J’ai installé le package eurosym, et j’arrive à compiler un exemple avec \euro sur le serveur en ligne de commande.

J’ai créé un scenaricustom.sty dans /usr/share/texmf/tex/latex/scenaricustom

\NeedsTeXFormat{LaTeX2e}
\ProvidesPackage{scenaricustom}

\usepackage[official,right]{eurosym}

Puis lancé un texhash

Je n’ai plus d’erreur à la génération concernant le \euro, en revanche la formule ne s’affiche pas. J’ai aussi l’impression que de toute façon le \euro n’est pas gérer par le rendu de la formule du coté Web.

Merci en tout cas pour les pistes, je vais continuer à chercher.