Erreur consultation génération web et papier opale

Bonjour,
J’utilise scénari chain desktop et opale dans leurs dernières version. Ce matin j’ai un problème lors de la consultation de la génération web:
image
Lorsque le fenêtre s’ouvre sous firefox j’obtiens cela:
image
Après avoir rechargé la page j’ai accès à la génération.
La différence par rapport à hier, j’ai fais une mise à jour java, est-ce que cela peut éventuellemnt venir de là?
image
Auriez-vous une idée? En vous remerciant.

Je viens de désinstaller puis installer à nouveau java le problème reste identique.

Bonjour,
Vous avez modifié vos paramètres de sécurité du navigateur ?
Bonne journée
Antoine
Kelis

Bonjour,
Non j’ai la version 90.0.1 64 bit de firefox.

Bonjour,
j’ai le même message d’erreur depuis ce matin avec Firefox, sous mac et nos serveurs Scenari 5, mais si je recharge la page, elle s’affiche ensuite correctement.
Pas de soucis avec notre serveur Scenari 4.2.
Merci,
Katia

Cela ressemble à un pb avec Firefox et la gestion de la sécurité ‹ SecFetch cross-site › : ils viennent de diffuser une nouvelle version 90.0.2 : pouvez-vous mettre à jour Firefox et nous dire si le problème persiste ?

Bonsoir,
Je viens de faire l’essai avec la version 90.0.2 et j’arrive à la même chose.

Bonjour,
pareil pour moi.

Bonjour,
même constat en SCENARIclientNG5.0 + Firefox 90.0 sous Ubuntu 20.10.

Fabien.

Après étude approfondie de ce problème :

  • il s’agit bien d’un changement de Firefox 90 qui a interprété différemment (par rapport à Firefox 89) le standard « SecFetch » (https://w3c.github.io/webappsec-fetch-metadata). Leur interprétation nous semble très discutable. Nous allons voir si on peut échanger avec eux et comprendre ce qui les a amené à ce changement surprenant que les navigateurs fondés sur Chromium n’ont pas adopté (à date).
  • concrètement, à date, il vous faut :
    • demander un rafraichissement de la page (F5, ctrl+R,…) pour passer outre ce pb
    • ou changer de navigateur par défaut.
  • ce problème peut aussi être contourné via une configuration particulière de SCENARIbuilder puis en recompilant votre serveur (réservé à ceux qui configurent leur propre serveur Scenari).
  • on étudie la possibilité d’un changement dans notre code générique pour contourner ce problème sans compromettre ce niveau de sécurité (sujets toujours délicats…).
1 « J'aime »

Merci pour votre retour.

Autre solution : désactiver ce contrôle de sécurité dans votre navigateur Firefox (il était désactivé par défaut dans Firefox 89 et précédentes versions, il vient d’être activé par défaut dans Firefox 90 mais en changeant en plus le comportement !).
Concrètement :

  • dans l’url, tapez « about:config »,
  • cliquez sur le bouton « Accepter le risque et poursuivre »
  • dans le champ de recherche, tapez « dom.security.secFetch.enabled »
  • cliquez sur le bouton « Inverser » à droite pour forcer la valeur à « false »
1 « J'aime »

Oui je vais cela merci beaucoup.

Bjr, je viens de faire la manip proposé par Sys spi, et je peux maintenant consulter les pdf postcriptum qui étaient jusqu’alors bloqués par Firefox.

Bonjour,

En conclusion, après discussions avec Mozilla, éditeur de Firefox, ils vont rétablir le comportement de Firefox 89, mais semble-t-il uniquement dans leur version de développement actuelle (Firefox 92), changement qui ne sera donc visible que dans quelques mois… En attendant, le changement de configuration comme indiqué dans mon précédent message semble la meilleur option.

1 « J'aime »

Merci beaucoup

Bonjour,
bien que cette solution fonctionne pour consulter les supports générés par Opale, il conduit à un effet de bord : plus d’accès à Facebook* ! Pas grave en soi (c’est peut-être même plutôt positif :grin:), on peut l’ouvrir dans un autre navigateur mais je me demande si d’autres effets de bord ne se manifesteront pas pour d’autres services.

Bonsoir,
Problème réglé avec la version 92 de firefox.

1 « J'aime »

Je confirme ! Merci pour l’info.