Emeraude, solution execice rédactionnel

Bonjour,

Dans un module Emeraude j’ai un grain de contenu, un exercice rédactionnel, encore un grain de contenu puis l’activité d’auto-évaluation finale.

Lorsque je publie le module Emeraude configuré sans les solutions de l’exercice et de l’activité finale, cela marche pour l’activité, mais pas pour l’exercice.
C’est dire qu’il n’y a pas les solutions de l’activité mais celles de l’exercice sont toujours présents.

Bug ou mauvaise configuration/utilisation de ma part ?
D’avance merci pour les réponses.

J’imagine que c’est parce que les exercices hors évaluation sont simplement pour l’auto-entraînement de l’apprenant et donc affichent la solution par simple clic. C’est pédagogiquement pour pouvoir proposer deux modes d’utilisation.
Cependant c’est peut-être une logique à revoir pour les exercices rédactionnels.
@christelle.larrouy aura surement un avis plus éclairé que le mien.

Disons qu’en général, dans les modules scenari, les choses ne sont pas faites au hasard. Mais là c’est un peu surprenant car cela m’oblige à créer deux fichiers, l’un avec la correction l’autre sans alors que l’option existe pour les générations.

Bonjour,
Je ne reproduis pas le comportement que vous évoquez.
Vous parlez bien de cet exercice rédactionnel, avec ce paramètre à non ?


Christelle

Bonjour et merci pour la réponse,
Oui, il me semble que nous parlons de la même chose.
Pour mieux s’en rendre compte je joins exemple Forum_2021-10-15.scar (483,3 Ko)

Dans Opale 3.8.012, avec l’exemple transmis, j’obtiens ce résultat :

(Et si je mets le paramètre « Publier les solutions des exercices rédactionnels » à oui, la solution s’affiche bien.)
Sur le support web, la prévisualisation, SCORM… j’ai le même résultat.

Qu’obtenez-vous de votre côté ?

Même version d’Opale mais quoi que je fasse la solution de l’exercice rédactionnel est toujours publiée …

Donc, pas de problème au niveau d’Emeraude A priori, il y aurait un conflit avec l’extension Conducteur pédagogique.
Pouvez-vous essayer de la désactiver au niveau des propriétés de votre atelier et vérifier que cela fonctionne ?

C’est fait, mais malheureusement cela ne résous pas le problème.

Vous avez raison. Je n’étais pas exactement sur la même version que la votre et le comportement est différent.
Vous pouvez télécharger la version « nightly » (3.8.014) ici : pack-Opale-3.8-sc50 [Jenkins].
Avec cette version, cela devrait fonctionner (mais toujours en désactivant l’extension).