Disponibilité de scserver 5.0.0.008

Bonjour,

J’ai un serveur scenari 5 installé sous Debian buster / Jetty installé via apt. Je viens de constater que les packages pour le version stable finale 5.0.0.008 n’étaient pas disponibles. J’ai installé la dernière nightly disponible soit la 5.0.7 20201124101537.
Par ailleurs et c’est un peu pour ça que je poste ce message, l’installation d’Opale 3.0.012 sur cette version rend les ateliers Opales inutilisables en WUI. Je m’en suis sorti pour le moment en revenant en opale 3.8.011 mais du coup j’en profite pour vous interroger sur le mise à dispo de scenari-server5 final.

Amicalement
Franck

Bonjour, j’ai posé la même question pour Ubuntu la semaine dernière et il me semble qu’ils doivent mettre à jour les paquets cette semaine.
Cordialement,

Bonjour,
Mince, je n’avais pas vu ton message. Bon ben ça fera un petit doublon désolé.
En tout cas merci pour le retour.
Bonne journée

Bonjour,

Tout à fait, des changements récents faits dans les méthodes de localisation et de compilation des produits Scenari ont rendu nos scripts de mise à disposition des debs inopérants.

On travaille à mieux intégrer la mise à dispo des debs dans nos méthodes de release… ça va prendre encore quelques jours… donc un peu de patience :slight_smile:

Thibaut

Bonjour,

Nous avons migré notre dépôt DEB, c.f. :

Suite à la mise en place de ce nouveau dépôt il est maintenant possible d’installer ou de mettre à jour les applications serveur (SCENARIchain-server, SCENARIchain-serverLite & SCENARIsuite-starter)

Une fois que vous avez ajouté ce nouveau dépôt à votre APT (et supprimé l’ancien) un simple apt upgrade ne suffira pas pour mettre à jour ces serveurs.
En effet ceci sont maintenant localisés et sont proposé en Français et en Anglais (tout comme les applications utilisateur SCENARI).
Vous devez :

  • choisir la langue que vous voulez installer
  • installer le package correspondant par ex :
    sudo apt install scenarisuite-starter5.0.fr-fr-jetty9

Bonjour,
Tout d’abord un grand Merci pour cet update :slight_smile:
Cependant la commande : sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0B77ECB798BEDF66
Me retourne une erreur :
Executing: /tmp/apt-key-gpghome.ZQWEjDWLgC/gpg.1.sh --recv-keys --keyserver keyserver.ubuntu.com 0B77ECB798BEDF66
gpg: keyserver receive failed: Connection timed out

Sinon si j’ai bien compris après avoir mis à jour les dépôts,
pour mettre à jour ma version 5.0.0.07RC sur ubuntu 20.04 je fais un :
sudo apt update
puis un (avec tomcat):

sudo apt install scenarichain-server5.0.fr-fr-tomcat9

cordialement,

Chez moi :
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0B77ECB798BEDF66
[sudo] password for sam:
Executing: /tmp/apt-key-gpghome.dnVfmsNTpC/gpg.1.sh --recv-keys --keyserver keyserver.ubuntu.com 0B77ECB798BEDF66
gpg: key 0B77ECB798BEDF66: « Kelis contact@kelis.fr » not changed
gpg: Total number processed: 1
gpg: unchanged: 1

Un pb réseau sur la machine en question ?

une action de gpg.1.sh est peut être bloquée par notre parefeu ?
il faut que je regarde de plus près, j’ai un time out

il y a un autre moyen d’ajouter la clef peut être ?

je vais essayer en http :
sudo add-apt-key -k hkp://keyserver.ubuntu.com:80 0B77ECB798BEDF66

Bonjour Sam,

Merci pour la mise à jour du dépôt. Je viens de faire la mise à jour sur mon serveur debian en suivant tes consignes. J’ai testé via un scenarichain-desktop (à l’ancienne) et tout semblait aller comme il faut. Sauf qu’en allant sur la version web depuis la dektop j’ai le comportement suivant :

Quand depuis sc-chain je clique sur naviguer J’arrive dans le navigateur avec une url sous la forme https://XXX.XXX.XXX.XXX:8080/scenarichain-server5.0/~~static/fr-FR/home.xhtml alors que dans le client lourd l’url est sous la forme https://monsite.fr/scenarichain-server5.0.

Le serveur se trouve derrière un reverse proxy. Donc l’adresse IP n’est visible que depuis VPN. et le port 8080 est bien sûr non accessible de l’extérieur. Donc l’adresse sous forme ip:8080 ne fonctionne pas à moins d’être en vpn. Dans ce cas là ça marche mais ce n’est pas le but.

Ensuite j’ai testé d’entrer directement dans le navigateur l’url du type https://monsite.fr/scenarichain-server5.0/~~static/fr-FR/home.xhtml et j’ai l’affichage d’un message d’erreur suivant
Une anomalie ne permet pas d'accéder à ce site.

Le même serveur hier avant maj ne faisait pas ça. Mais j’ignore si il y a eu d’autres interventions que la mienne qui pourrait compromettre l’analyse ci-dessus.

Si vous aviez une idée
Merci d’avance
Franck

ça marche avec :
sudo apt-get install add-apt-key
sudo add-apt-key -k hkp://keyserver.ubuntu.com:80 0B77ECB798BEDF66

Re bonjour,

Y a t’il un endroit où je pourrais trouver un log quelconque qui pourrait m’aider à débloquer la situation ? Sinon je vais devoir demander un retour au précédent backup de la VM.

Merci d’avance
Franck

Re Bonjour,

Bon j’ai finalement trouvé. En fait je n’ai pas pensé que de lancer un apt install à la place de l’habituel apt upgrade toucherait aux fichiers de config, j’avais la config par défut liée à l’install.
Une fois les fichier /etc/scenarichain-server5.0/conf/webapp.properties et users.properties reparamétrés puis reconfiguration de la webapp, le service est reparti

Good news
Encore merci pour le nouveau dépôt deb
Franck

Salut Frank, merci pour le retour !

Bonsoir, ça marche pour moi aussi, j’ai dû refaire les fichiers de conf aussi, notamment pour la liaison ldap mais tt est ok. Je vois que le fonctionnement du client web a sensiblement changé pour la gestion des ateliers.

Salut Sam,

Petit message pour rappel de faire la maj de la doc d’installation de scserver debian.ubuntu avec tes nouvelles infos.

Franck

oui bien-sûr, c’est en cours…

Vola, les docs d’installation de des applications SCENARI client, chain, server, serverLite, suite-starter 5.0 son maintenant à jour.