Dégradation qualité images plein écran


#1

Bonjour,

J’ai modifié la charte Mirage de Topaze pour que les images dans les blocs “ressources” soient en plein écran et j’ai remarqué que même si mon image était en très bonne qualité et paramétrée à 100%, lors de la génération elle devenait floue, est-ce qu’il y a possibilité d’éviter ce problème ? Est-ce un paramètre dans builder ou cela peut se gérer avec Styler ?

Bien cordialement,

Gaëlle


#2

Bonjour,

Par défaut les transformeurs ne vont pas prendre la résolution native de
l’image, mais juste ce qu’il y a besoin pour les usages actuels de la
skin sans que le fichier soit trop lourd, donc augmenter la taille
uniquement coté CSS rend souvent l’image floue.

En général, il y a un fichier à modifier dans la skin pour changer la
résolution. Peut être :
https://trac.scenari.org/topaze/browser/versions/sc42-v1.5.0.38/model/sources/mirage/web/mirageW.skin.doss/~options/init.properties

a+

Stéphane


#3

Il n’y avait qu’une ligne non commentée, j’ai d’abord tenté d’augmenter la valeur puis de commenter la ligne mais je ne vois aucun changement, mes images sont toujours floues… Une autre idée ?


#4

Quelqu’un aurait une autre proposition ? :slight_smile:


#5

Salut Gaelle,
Tu as un exemple publiquement visible pour que je regarde dans le détail ?


#6

Bonjour Sam,

Oui, voici un exemple très court pour illustrer le problème. Pour voir avec la charte, il y a un zip de l’export web ici et si besoin, voici le scar du module (mais je ne sais pas si cela est utile sans la charte) :
Test_img_2018-3-8.scar (1,3 Mo)

Merci de ton aide,


#7

Salut Gaelle,

Donc, les images dans le ZIP sont toujours avec un max de 1200px, en effet sur un très grand écran cela devient floue. Il faut passer la ligne bin.size-int du fichier ~options/init.properties de votre skin à plus que 1200.

Tout dépends de la taille de tes écrans, personnellement je pense que 2000 doit être suffisant. Il faut surtout pas commenter la ligne bin.size-int car alors ce sera la valeur par défaut qui sera pris, qui doit être 630px.


#8

J’avais testé cette solution précédemment, mais en le mettant à 2000 comme beaucoup plus, cela ne change absolument rien… Il y a autre chose à faire pour que cela soit pris en compte ?


#9

Explique moi exactement ce que tu a fait, tu a changé cela ou ? dans SCENARIstyler, puis compilé le skinpack avec une nouveau numéro de version ? puis installé dans scChain ?


#10

Oui, j’ai juste changé les caractéristiques de : .topaze .res .resInFlow_co>img dans le fichier main.css, j’ai compilé le skinpack dans une nouvelle version depuis styler et réinstallé dans scChain


#11

et je peut avoir le skinpack ?


#12

Gaelle, j’ai trouvé, en effet Mirage ne respectait pas la directive du fichier init.properties, c’est corrigé dans Topaze et sera dispo dans la prochaine version.


#13

Ah ! Merci pour cette réponse, vivement la prochaine version alors !
A-t-on une date approximative de la sortie de cette version ? :slight_smile:


#14

Salut
Normalement Katia doit tester une prochaine version la semaine prochaine. Si il n’y a pas de bugs, cela ne devrait as tarder après …


#15

Super nouvelle ! Merci beaucoup !