Basar dérivé Opale


#1

Je cherche une solution pour utiliser scenari Basar avec scenari Chain 4.1.

Une idée ?


#2

Bonjour,

Il faut reprendre les sources de basar et passer par scenaribuilder 4.1 pour créer un pack compatible avec scenarichain 4.1.
Le projet est-il encore soutenu ou à l’abandon, et les sources sont-elles disponibles ? En tout cas il est intéressant.

Bruno


#3

Si on me dit où trouver les sources, je veux bien tenter le portage :slightly_smiling:


#4

J’attendais de voir passer une réponse indiquant où se trouve les sources, pas de réponse ?
Il faut aussi voir si la licence permet de faire le portage.


#5

Bonjour,
J’arrive peut-être un peu tard ?? Sur le site du projet Basar, on trouve des sources pour sc 4.0 semble t-il.
Aller sur la page : [http://www.projetbasar.net/index.php/fr/formation/supports-de-formation]
Il faut télécharger le dossier zip : pack_basarv1.0.zip
Deux wsppack sont disponibles. Je n’ai pas pu les installer sur la version 4.1 mais peut-être sont-ils toujours fonctionnels sur SC 4.0 ??
Copie d’écran :


A voir.


#6

Bonjour à tous,

Le projet Basar devrait être diffusé sous forme d’extension à Opale d’ici 1 ou 2 mois au fil des sorties des modèles compatibles avec la 4.2.
Quelques évolutions sont à prévoir par la même occasion (skin, commentaires…)
Bonne journée à tous
Ludovic


[Résolu] Qu'en est-il du modèle Basar ?
#7

Bonjour,

Je me pose une question, dans myscenari peut-on facilement injecter une telle extension ?

Bruno


#8

Bonjour Bruno,

Non, pour des raisons de sécurité en particulier, les utilisateurs ne
peuvent pas ajouter leur propre modèle. Ils ne peuvent qu’ajouter des skins.
En ce qui concerne la liste des modèles proposés, pour des raisons de
maintenabilité, de durabilité, et de compatibilité ascendante, myScenari
ne contient que des modèles qualifiés de “produits” (cf définition de
"produit vs projet" ici : https://scenari.org/co/modeles.html).

Sylvain


#9

Bonjour Sylvain,

Merci pour cette précision, un modèle opale + une extension (comme basar) est donc considéré comme projet.
Tu précises que c’est pour des raisons de sécurité, si moi je monte un serveur scenari, je pense faire des essais en intranet dans un premier temps, dois-je interdire l’installation d’extension ?

Bruno


#10

Un “.wsppack” (nouveau modèle documentaire ou extension), contient du
code exécuté sur le serveur.

Seules les personnes avec le plus haut degré d’habilitations sur un
server doivent détenir les droits d’installer un “.wsppack” car un
utilisateur malveillant déployant un wsppack pourrait parvenir à
extraire ou modifier des données sur le serveur auxquelles il ne devrait
pas avoir accès.

Le déploiement d’un “.skinpack” ne pose lui pas de difficulté en terme
de sécurité.

Sylvain