Affichage video ubicast dans Opale

Bonjour,
Nous rencontrons des difficultés dans l’affichage de videos distantes stockées sur notre serveur video ubicast. Cela s’affiche et s’edite sans problème dans les navigateurs Chrome, Vivaldi ou Brave mais pas dans scenarichain desktop 5.0

Voici le message que j’obtiens quand j’essaie de prévisualiser la video :

Impossible d’accéder à la ressource audio ou vidéo à l’adresse : Exemple de Videoscribe sur la fabrique de compétence - MediaServer - cnam

La ressource n’est plus disponible ou vous n’êtes pas autorisé à y accéder. Veuillez vérifier votre accès puis [recharger le média]

en essayant de créer la video à partir de scenarichain desktop, voici le message qui s’affiche :

Avez vous une idée de l’origine du problème ?

Merci par avance de votre aide :grinning:

Salut, peut-être un problème de firewall qui affecte scChain.
Peut-tu essayer avec scChain NG ? C’est comme scChain mais avec la nouvelle interface d’édition.

Merci Loic
En fait, le pb se trouve sur la partie serveur et sur scChain NG on travaille en local non ?

hmmm, en effet, je n’ai pas trouvé comment se connecter à un serveur sur scChainNG.
Je n’ai pas de solution à part de conseiller de travailler depuis le navigateur.
Poke @sam

Bonjour,

avec SCENARIclientNG

Merci Sylvain, ça me fait la même chose…
Dans l’edition la video apparaît très furtivement et puis disparait et ensuite j’ai un affichage qui dit « video non disponible »
Peut-être un problème à regler coté DSI ?

Bonjour,

Il semble que oui. Le serveur ne permet les accès aux vidéos qu’à partir des pages du domaine cnam.fr, ce qui exclu l’accès à partir d’un chain-desktop (dont le domaine est localhost). Techniquement, il s’agit d’un problème de configuration des CORS.

1 « J'aime »

C’est donc logique avec SCchain-desktop, c’est un verrou de sécurité du coté de votre serveur de video. C’est par contre moins logique avec SCENARIclientNG car si cela fonctionne dans un navigateur, cela devrait aussi marcher, sauf configuration très spéciale de votre serveur video.

Avec le SCclientNG, vous avez bien pointé le même serveur que celui que vous avez interrogé par le navigateur et où la video fonctionnait ?

Vous pourrez avoir plus d’informations, en allant dans le menu tout en haut à gauche de la fenêtre de SCclientNG, puis menu « Fenêtres » et « Outils de développement de la page… ». Cliquez alors sur l’onglet « Console » et essayer d’ouvrir un item qui inclut cette vidéo. Des messages techniques apparaissent-ils ?

Merci :wink:
oui voilà ce que j’ai :

ça se configure où les CORS, sur le serveur video ou sur le serveur scenari ?

Sur le serveur vidéo : ils doivent autoriser le domaine de votre serveur Scenari.

1 « J'aime »

Merci, je vais donner les precisions au gestionnaire du serveur video.