Activation de Google Analytics

Ça fait bien un an que j’ai tenté d’activer Google Analytics dans OptimOffice sous MyScenari mais sans succès.
La saison aidant, je me remets à la tâche…

J’ai rempli le formulaire dans OptimOffice :
image

… à partir de la page ID de suivi sur Google Analytics :

Lorsque j’appuie sur le bouton Envoyer le trafic test , le site s’ouvre dans Chrome mais il n’y a aucun trafic en temps réel détecté par Google Analytics.

De plus, j’ai activé la Google Search Console et elle me donne quelques infos :

Toutefois, il n’y a rien de capturé par Google Analytics :

J’ai remarqué quelques différence entre le code généré par OptimOffice et celui recommandé par Google Analytics.

Le code généré sur mes pages OptimOffice est :

image

Alors que le code recommandé sur le site Google Analytics est :
image

Vous avez une idée sur ce qu’il faut faire pour activer Google Analytics?

Vous remerciant à l’avance,

Michel

Bonjour
Il est possible que le code à intégrer ait changé.
Je vais regarder …
Cela étant pour tester vous pouvez remplacer sur certaines pages le script précédent par celui que vous avez recopié. Si cela marche nous serons fixé …
Cordialement
Nicolas

Vous pouvez aussi tester en utilisant cette extension pour tester votre configuration :

Edit :
Il s’agit en fait de deux méthodes différentes pour enregistrer votre site.
La deuxième utilise gtag, la premiere analytics :
Le code donné par défaut par google est le suivant :

<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-XXXXX-Y', 'auto');
ga('send', 'pageview');
</script>

Cela me semble donc correspondre à votre code …
Il doit donc y avoir un autre problème …

Pour démonstration du problème, j’ai créé spécifiquement un site web très simple : https://michelsabourin.scenari-community.org/DemoOptimOffice .
Google Analytics n’est pas activé.

Il faudrait vraiment trouver une solution.
Pour référence mon atelier est joint
DémoOptimOffice_2019-8-6.scwsp (1,8 Ko)

Merci pour votre attention.

Bonjour,

La prochaine version de Optim comportera un test de conformité sur le nom de domaine utilisé dans les options de Google Analytics :

Et quand c’est bon :

Bonjour Samuel,

Juste te dire que j’apprécie beaucoup ton support diligent et tes remarques toujours pertinentes. J’ai eu des problèmes avec mes courriels ce qui explique ce délai.

Dns le cas présent, j’ai bien appliqué le correctif. Ça ne marche pas.

Ce que j’ai observé c’est que la page pointée par https://michelsabourin.scenari-community.org/ ne comporte pas le code magique alors que les suivantes par exemple https://michelsabourin.scenari-community.org/SimTurb/co/1siteWeb.html comporte bien le code:

Encore merci pour ton support et ta patience envers un non spécialiste en programmation.

Michel

Provenance : Courrier pour Windows 10

Bonjour Michel,

Alors, ce sont deux problèmes différents :

  1. Tout d’abord votre site sur les turbines :
    Visiblement ce site n’est pas encore à jour avec la correction du champ « Nom de domaine » dans l’item « Statistiques Google Analytics » car je retrouve toujours https://michelsabourin.scenari-community.org en non pas michelsabourin.scenari-community.org autrement-dit il faut enlever les caractères https:// au début de ce champ puis regénérer et redéploiyer votre site.
  2. La racine de votre domaine MyScenari (https://michelsabourin.scenari-community.org) :
    Ceci est une page par défaut construite par le SCENARIdepot de votre domaine MyScenari pour permettre la navigation dans les dossiers de votre dépôt, elle ne fait pas partie d’une publication web généré par vous dans SCENARI. Il est donc tout a fait normal qu’elle ne comporte pas votre code GA.
    Il et néanmoins possible de personnaliser les accueils de dossiers de dépôts en utilisant un mini site Optim, par exemple :
    Pour en cacher le contenu : https://sam.scenari-community.org/temp/ ;
    Pour mieux en organiser la structure : https://stph.scenari-community.org ou https://stph.scenari-community.org/doc/
    On peut dans ce cas accrocher le même item « Statistiques Google Analytics » et la vue racine du dossier contiendra bien le code GA. Pour ce-faire il suffit de :