[WON'T FIX]{scenarichain-server5.0,scenarichain-serverlite5.0}-tomcat9 installation impossible pour Debian 10 Buster

Bonjour,

Pour info pour Debian 10 Buster et dérivés :

apt update && \
apt-get install --no-install-recommends {scenarichain-server5.0,scenarichain-serverlite5.0}-tomcat9

Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
 scenarichain-server5.0-tomcat9 : Dépend: tomcat9 (>= 9.0.20) mais ne sera pas installé
 scenarichain-serverlite5.0-tomcat9 : Dépend: tomcat9 (>= 9.0.20) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

La version de tomcat9 actuellement disponible :

apt-cache madison tomcat9; apt-cache policy tomcat9

   tomcat9 |   9.0.16-4 | http://ftp.fr.debian.org/debian buster/main amd64 Packages
   tomcat9 | 9.0.16-4~bpo9+1 | http://ftp.fr.debian.org/debian stretch-backports/main amd64 Packages
   tomcat9 |   9.0.16-4 | http://ftp.fr.debian.org/debian buster/main Sources
   tomcat9 | 9.0.16-4~bpo9+1 | http://ftp.fr.debian.org/debian stretch-backports/main Sources
tomcat9:
  Installé : (aucun)
  Candidat : 9.0.16-4
 Table de version :
     9.0.16-4 990
        990 http://ftp.fr.debian.org/debian buster/main amd64 Packages
     9.0.16-4~bpo9+1 100
        100 http://ftp.fr.debian.org/debian stretch-backports/main amd64 Packages

Proposition de résolution du bug :

  • soit fournir le dépôt deb-src pour permettre une modification du fichier debian/control et une re-construction du paquet par les développeurs tiers
  • soit faire la modification vous-même

Cordialement,

SCENARIserver n’est compatible qu’avec Tomcat 9.0.20 minimum.
Utiliser un Tomcat inférieure implique que la gestion d’édition concurrente ne marchera pas car le Websocket Asynchrone n’y est pas inclus on activé.

C’est noté, je marque le bug en « WON’T FIX » et je testerai les paquets concernant la branche 5.0.x de Scenari lorqu’ils seront compatibles avec Debian 10 Buster.

Merci pour votre réponse.

Nous conseillons maintenant d’utiliser Jetty, plus léger que Tomcat et amplement suffisant pour faire tourner SCENARI.

Bug « FIXED » en ajoutant les dépôts testing aux sources.list.

Merci pour le support et les conseils concernant le choix d’un conteneur de servlets respectant la RFC 6455.