Topaze 1.5 - "Stackoverflow" lors de la génération

Bonjour,
Nous utilisons Topaze 1.5. Tout fonctionne parfaitement en dessous de 50 étapes. Mais si on rajoute une étape de plus, la génération ne se passe plus comme il faut. Il s’agit d’étapes “d’orientation” avec une image et des zones cliquables.
Quand on lance la génération, le message d’erreur indique “stack overflow”.
Y a-t-il une explication rationnelle ?
Merci d’avance pour votre aide.
Sacha

Bonjour,

Deux possibilités:

  • soit il y a une erreur dans vos contenus qui créée une sorte de
    boucle infinie que Topaze ne détecte pas et qu’il faudrait alors que
    nous traitions (pour remonter une erreur plus explicite),
  • soit vous arrivez à une limite ‘normale’ d’espace mémoire disponible
    dans le système de génération. Il faut alors changer la
    configuration de l’application pour lui allouer plus d’espace
    mémoire. Utilisez-vous Topaze en version ‘desktop’ ou en version
    client-server ?

Sylvain

Bonjour Sylvain
Merci beaucoup pour votre réponse rapide !
Nous travaillons en mode “mono-poste”.
Je vais rechercher tout de suite où je peux allouer plus de mémoire à la génération.
Sacha

Ok trouvé ! C’est dans “Préférences / Avancé / Entrepot local”.
Merci mille fois Sylvain !!!
Sacha

Hum, en principe non, ca ne résoudra pas votre problème. C’est un autre paramètre qu’il faut changer, mais nous n’avons pas mis à disposition une interface graphique pour le modifier.
Si vous me confirmez que ca ne marche pas mieux, je vous donnerai la procédure.

Ah bin non… ce paramètre n’y change rien.

Pour changer ce paramètre :

  1. Lorsque vous avez une fenêtre de l’application Scenari, tapez la combinaison de touches Ctrl+shift+K.
  2. Une fenêtre Configuration avancée s’ouvre avec “Attention danger” en gros… Cliquez sur le bouton Je ferai attention, promis !
  3. Tapez dans le champ de recherche “scenari.jvm”, la liste en dessous se réduit à une seule ligne scenari.jvm.options.
  4. Double-clisuez sur cette ligne pour éditer sa valeur (qui devrait-être vide), et saisissez “Xss2M” :
  5. Validez cette petite boite de dialogue, fermez cette fenêtre de Configuration avancée et quittez l’application Scenari.
  6. Attendez quelques secondes…
  7. Relancez Scenari et testez à nouveau la génération

Désolé pour le délai. Merci pour la réponse, mais cela ne fonctionne pas.

Quand le paramètre est changé en 'Xss2M", Topaze n’aarive plus à ouvrir les ateliers loacaux : ateliers inaccessibles…

:frowning: quand je retire le paramètre, les ateliers s’ouvrent de nouveau.

TROUVE !! Un copain balèze m’a dit qu’il manquait un “-” devant le paramètre JVM.

Donc la manip’ est la bonne, mais avec “-Xss2M”.

** Problème résolu ***

Merciiiiiii !

Quel est votre système d’exploitation : Windows, Linux ou MacOS ?
De quel espace mémoire votre système dispose ?

On est sous Windows avec 8Go de RAM.