Progressive Web App pour Opale

Bonjour,

J’ai fais des essais pour TechnOpale sous android et je pense avoir un résultat correct de la publication (bouton «plus» pour ajouter à l’écran d’accueil et hors ligne OK).
Cette publication est-elle compatible avec IOS d’Apple car je n’ai trouvé personne pouvant me dire si cette publication fonctionne sur un iphone (pas de bouton sous safari et/ou chrome (!) sur iphone) ? Si oui merci de m’expliquer ce que je dois faire pour vérifier mes tests.
Cordialement,
Bruno

Bonjour
Le fonctionnement hors ligne doit normalement fonctionner sous IOS safari, chrome ou Firefox. L’installation je ne pense pas, ce qui expliquerait qu’il n’y ait pas de bouton.
Cordialement,
Nicolas

Merci Nicolas pour cette réponse mais la personne fait quoi concrètement.
Elle commence à lire le site et il se met tout seul en historique ?
Comment fait-il pour revenir sur le site une fois que la personne a quitté la page (navigation sur un autre site, navigateur fermé historique effacé…) ?
Bref je n’ai pas trouvé comment l’utiliser sur IOS (je n’ai pas d’Apple).
Cordialement,
Bruno

La personne n’a effectivement rien à faire sur n’importe quel OS pour que le contenu soit disponible hors ligne. Le seul impératif est que le site ait été visité au moins une fois.
Quand un site a un Service Worker et que tout est bien mis en place dans le manifest, le site est alors mis en cache automatiquement dès la première visualisation si tu reviens sur le site même hors ligne, le site est disponible.

Le principe d’installation n’est dispo que sur certains navigateurs (chrome essentiellement et sans doute les navigateurs basés sur Webkit …)

1 J'aime

Bonjour,
J’ai fait un petit test avec un module Opale tout bête mais qui contient un média enrichi.
En effet il n’y a rien à faire pour tout ce qui est page contenant du texte et quiz mais la vidéo ne s’affiche pas une fois qu’on passe hors ligne.
J’ai bien pris soin de lire la vidéo (deux fois) avant de couper la connexion. J’ai juste un semblant de lecteur dont le bouton de lecture reste inopérant.
Testé avec Brave.

Bonjour
Le media est intégré au contenu ou est ce un media distant ?
S’il est intégré avez-vous bien mis oui dans la propriété de génération : « Mettre à jour les vidéos » ?

Le média est intégré.
Tout est sur « oui » mais je le comprends plus comme, « si la vidéo est modifiée, la nouvelle version remplace l’ancienne » et pas « je stocke la vidéo en local ».
Je n’ai pas trouvé de documentation.

Pour info le module est là : http://jacob.patrick.free.fr/app/

Bonjour,

Le problème semble plutôt provenir de deux choses :

  • premièrement vous n’êtes pas en https donc pas sécurisé et c’est un prérecquis important.
  • les icones le respectent pas la taille demandée 192*192 et 512*512

On peut voir ça dans l’onglet application des outils de dev de chrome dans la partie Manifest
Cordialement,
Nicolas

Merci pour la réponse rapide.
En effet, si je met le module sur mon dépôt myscenari, la vidéo est visible hors-ligne.
Bonne fin de semaine.