Formules LaTeX Quetzal


#1

Bonjour

Les formules LaTeX ne s’affichent pas dans la publication Web . La génération arrive à son terme sans message d’erreur, mais les formules ne s’affichent pas dans les pages web !

A noter que sur mon Scenari4.2, ça fonctionne avec les générations Opale_Web_Aurora et Ruby_Web_prism, mon installation LaTeX ne semble pas en cause .

macOS Mojave : 10.14
ScenariChain-server 4.2.1.06 final
Quetzal 3-4

Quelqu’un a une idée ?


#2

Bonjour,
Est-ce que vous avez essayé de publier sur Opale Web Quadra ?
Il semble que la génération d’une formule Latex dans Quetzal ou dans Opale Quadra est la même (rendu sous la forme d’une image PNG).
Si vous avez le même problème, il manque peut être des paquets à votre installation latex.

Dans la doc d’installation d’un Scenari serveur sous Linux, les paquets Latex nécessaires sont indiqués


#3

merci our la réponse

Effectivement j’ai le même problème avec Web Quadra, j’obtiens des messages d’erreurs de type :

Cannot run program "latex" (in directory "/var/folders/_p/p77dpsyx0x39fx34f5qdhkwc0000gn/T"): error=2, No such file or directory

Le dossier /var/folders/_p/p77dps…… existe bien.

Tous les pacques LaTeX sont installés et à jour.

Je pense qu’il s’agit d’un problème de configuration, mais je ne trouve pas.


#4

Bonjour,

Sous MacOSX SCENARI est configuré pouur utiliser MacTex (https://doc.scenari.software/Opale@3.7/reference/fr/#maths:6.6:MPKrRXGaEzjo38mU48LGrj) C’est votre cas ?


#5

Oui, c’est ce que j’ai installé.
ça fonctionne quand les formules sont affichées via MathJax (web aurora), mais pas quand elles sont converties en image (web quadra ou quetzal)


#6

Par MathJax, c’est normal que ça marche, Latex n’est pas invoqué.

Je viens de tester chez moi sous MacOSX 10.14 avec Mactex fraichement installé en utilisant la SCEANRIapp Opale 3.7 et ça marche.

Vous parlez de SCENARIchain-server … Vous avez installé SCENARIserver sous Mac ? vous voulez pas plutôt parler de SCENARIchain-desktop ?


#7

oui effectivement c’est SCENARIchain-desktop .

Avec opale 3.7, même problème.